PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not displaying correctly

  1. First time poster, sorry couldn't find my answer in other post.

    Could it be my theme? The preview is very different from what I actually see display to users.

    Users see this: http://img822.imageshack.us/img822/8202/usersa.jpg

    My preview shows me this: http://img824.imageshack.us/img824/3929/previewszv.jpg

    I tried using different settings, output css, output html, no conflict but received the same results. I've also tried using different browsers. Any help would be appreciated.

    PHP Version 5.3.21
    MySQL Version 5.0.96
    WordPress Version 3.5.1
    Gravity Forms Version 1.7.2

    Posted 9 years ago on Friday April 26, 2013 | Permalink
  2. David Peralty

    Can you try with the default WordPress theme to see how it looks for you?

    Posted 9 years ago on Friday April 26, 2013 | Permalink
  3. Good call David, and your right, the form does display correctly with the default theme. Any workarounds for this. Thank you for the quick reply.

    Posted 9 years ago on Friday April 26, 2013 | Permalink
  4. David Peralty

    Sounds like you'll have to figure out what CSS your specific theme is applying to the form and edit or disable it. There isn't an easy walkthrough for this because it is specific to your theme.

    Posted 9 years ago on Friday April 26, 2013 | Permalink
  5. Richard Vav
    Administrator

    If you can share a link to a page containing the form in question we can take a look and may be able to offer more specific advice.

    Regards,
    Richard
    --
    Just another member of the community helping out where I can

    Posted 9 years ago on Friday April 26, 2013 | Permalink
  6. Thank you all, the link in question is http://clovisrayscholarship.org/apply/ if that helps.

    Oops I will shut off the maintenance mode for wordpress now. Should work now.

    Posted 9 years ago on Friday April 26, 2013 | Permalink
  7. Richard Vav
    Administrator

    Your themes style.css contains the following CSS which is screwing around with the positioning of the gravity form field labels

    label {
        position: absolute;
        top: 7px !important;
        left: 15px !important;
        color: #aaa;
        font-weight: normal;
    }

    To counteract that you can add the following

    .gform_wrapper label {
        position: static !important;
    }

    you should end up with this http://imgur.com/tstMqAF

    Posted 9 years ago on Friday April 26, 2013 | Permalink
  8. Thank you that worked perfectly .

    Posted 9 years ago on Sunday April 28, 2013 | Permalink
  9. Richard Vav
    Administrator

    You're welcome

    Posted 9 years ago on Sunday April 28, 2013 | Permalink