PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not redirecting to PayPal on Submit

  1. I've reviewed the posts in this forum but can't seem to find a solution. I recently upgraded to the developer version of Gravity Forms so I could take advantage of the PayPal Add-On. I updated my site last week and tested and everything seemed to be working. I had a submission today from a user and she was not taken to the PayPal page upon submission of the form. I have subsequently tried myself and am having no sucesss. I've reviewed the documentation, tried several configurations and it still does not seem to work. My website is http://vansos.com and the form is located under the Program Menu --> Apply Now!

    Happy to provide login credentials to get this working.

    Thanks!

    Posted 8 years ago on Tuesday November 1, 2011 | Permalink
  2. Hi NBurdeny,

    I suspect this might be a theme or plugin conflict. Try walking through this documentation to determine if this is the case:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Let me know the verdict.

    Posted 8 years ago on Tuesday November 1, 2011 | Permalink
  3. Question... if I activate the default theme, will I loose what I have developed with my other theme? I do not want to have to re-do the site.

    Posted 8 years ago on Tuesday November 1, 2011 | Permalink
  4. Hi NBurdeny,

    You should be able to change themes freely without any loss of data. :)

    Posted 8 years ago on Tuesday November 1, 2011 | Permalink
  5. Test #1 - Changed Theme to default and tried form submission. No change.
    Test #2 - Deactivated all plug-ins. Reactivated only Gravity Forms and PayPal Plug-In. Retested. No change.

    Next suggestion?

    Posted 8 years ago on Tuesday November 1, 2011 | Permalink
  6. Have you defined a PayPal condition? Or should all transactions go to PayPal? Is there a chance of a zero dollar transaction? That won't be sent to PayPal either.

    Posted 8 years ago on Tuesday November 1, 2011 | Permalink
  7. Yes, I have defined a PayPal condition. All transactions are to go to PayPal. I have set the transaction amount to $15

    Posted 8 years ago on Tuesday November 1, 2011 | Permalink
  8. Should clarify... the condition defined is one of the check-boxes on the form. They have to click in the first box to activate the form. The same condition is set at the form level. I have tried with this option disabled as well, but when the form was working last week, it was enabled.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  9. Can you export your form as XML please and email it to me as an attachment?

    chris@rocketgenius.com

    Thanks

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  10. Also, does it work in the form preview?

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  11. Yes it does work in the preview. Sending the XML now.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  12. If the form works in the preview, it's likely a plugin or theme conflict.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  13. I tested the form and there is definitely something weird going on. I saw that it was trying to contact paypal.com but then just reloaded with a blank frame. I wonder if it has something to do with the iframe? I could never get the address bar to reflect the actual page I was on, then I noticed the iframe. I wonder if that is hurting things somehow?

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  14. Looking further at this, it appears this is an IIS/Windows server. There are issues with permalinks and rewriting on IIS in general and IIS 6 in particular. It got better with IIS 7 but we shave better luck when hosting WordPress on an Apache/Linux server.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  15. I installed your form on my site and configured a paypal feed. I used the one same condition (the initial checkbox you need to check to see the form) and I was directed properly to paypal.

    Here's the form on my site:
    http://gravity.chrishajer.com/apply-now/

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  16. Okay so, I'm not hosting on a Apache/Linux server and don't plan to be... what can we do to resolve this issue? Also, my notifications weren't working properly but when I used your site, they came through perfectly. Double whammy!

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  17. Why is your site loading in a frameset? We believe the issue is related to the very non-standard way in which your site loads within framesets the way it does. Can you explain why your site is setup this way using frames when it doesn't appear to be a situation where frames are necessary?

    The form is redirecting to PayPal. But it appears the convoluted way in which your theme is setup is causing a problem for PayPal loading. See this screenshot, look at the last 2 requests in the FireBug panel: http://i.imgur.com/xr8OH.png

    Those are the redirects to PayPal which are triggering... at that point Gravity Forms isn't involved. PayPal tries to load the checkout page but the frameset setup of your site appears to be interfering in allowing this to happen.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  18. Your guess is as good as mine. I host with GoDaddy. I installed WordPress and the Striking theme. I am not technical enough to have done anything special other than those two things and then add your plug-in. Suggestions? It's a little greek to me.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  19. This is unusual. I've actually never seen a WordPress site that does this with framesets the way yours is.

    Your entire site loads in a frame. The frame loads the site from here:

    http://natalieburdeny.com/vansos

    See this screenshot of the source code when I go to http://vansos.com:

    http://dl.dropbox.com/u/185347/Slingshot/Pictures/Screen%20Shot%202011-11-02%20at%2012.30.42%20PM.png

    Do you know why the actual site is located at http://natalieburdeny.com/vansos instead of actually at http://vansos.com which is the link you provided?

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  20. I have one hosting package for multiple sites. It was suggested that I create a subfolder off my site for VanSOS... The domain is pointed to http://natalieburdeny.com/vansos. Wordpress is installed in the vansos folder. I'm not sure i can do things differently.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  21. The problem appears to be the framesets are confusing PayPal. It doesn't know where to link to because the URL is not the correct one.

    I've never seen multiple sites on a single host setup this way, even with GoDaddy.

    You should be able to point your domain name to a specific site/folder on your host. You shouldn't need to be doing framesets the way you are.

    You may want to discuss this with GoDaddy to see what you can do differently.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  22. I honestly don't know where framesets come into any of this. I certainly didn't set them up, but I will inquire with GoDaddy and see what they say.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  23. Just logged into my GoDaddy account. I had the vansos doman forwarded with masking to the folder on the nb account. I've cancelled the forwarding and added the vansos domain to my nb hosting on the folder vansos. Not sure if that makes sense. It says it will take up to 24 hours to process. Fingers crossed this may resolve the issue... my thoughts are it's a DNS issue. I'll update when I have some information.

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  24. Okay, I think the issue is fixed. I updated the permalinks on the site but choosing a non-default format, saving, and then going back to the default and saving. Links are now showing full paths. Tested in IE, Safari and Chrome... redirection worked on all counts! No notifications though... boo!

    Posted 8 years ago on Wednesday November 2, 2011 | Permalink
  25. GoDaddy is notorious for email delivery problems. You should contact their support and find out what settings to use for an SMTP server, then install the WP Mail SMTP plugin.

    http://wordpress.org/extend/plugins/wp-mail-smtp/

    Posted 8 years ago on Thursday November 3, 2011 | Permalink
  26. jtdesign00
    Member

    Running on Linux server. Have a test form setup as basic as possible with just one product field - not redirecting to PayPal and I'm not sure what is missing. IPN PayPal settings configured, Order Form setup under PayPal settings. Everything appears to be in place but I can't figure out what is missing... Thanks in advance!

    Also, tried different theme, deactivating plugins, etc. with no luck.

    http://www.crossfitadvanced.com/test/

    Posted 8 years ago on Monday February 13, 2012 | Permalink
  27. jtdesign00, please start a new topic for your issue so we can better address it. Thank you.

    Posted 8 years ago on Saturday February 18, 2012 | Permalink

This topic has been resolved and has been closed to new replies.