PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not showing after update

  1. I just updated to v1.6.4.5.4 and now 2 of my 3 forms won't show up. The shortcode is still there; I have tried removing it and re-adding it. I saw in a related post http://www.gravityhelp.com/forums/topic/after-update-to-v1641-form-not-displaying that you mention to deactivate a mailchimp plugin. I did that but nothing worked. I have activated Twenty Eleven theme and reactived mine but nothing. I have checked in Firefox, Chrome and Explorer. Here is the site, can you possibly help?!
    http://grantsburgdollarsforscholars.com/ - Form on front page works fine
    Donate Page and Events>Golfing for Grads should have forms.

    Posted 7 years ago on Tuesday June 26, 2012 | Permalink
  2. David Peralty
    Administrator

    Can we have you quickly try the following troubleshooting steps:
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Can you preview the forms that aren't working?

    Posted 7 years ago on Tuesday June 26, 2012 | Permalink
  3. It does not appear the upgrade went well. Looks like you still have Gravity Forms version 1.6.3.3.4 installed. Can you try deleting the gravityforms plugin folder, then reinstalling using FTP? You can download the plugin from here: http://www.gravityhelp.com/downloads/

    Deleting the plugin folder will not cause you to lose any forms or entries.

    There is a JavaScript error on the page which is preventing the form from showing:

    Timestamp: 6/26/2012 12:17:47 PM
    Error: gf_global is not defined
    Source File: http://grantsburgdollarsforscholars.com/wp-content/plugins/gravityforms/js/gravityforms.js?ver=1.6.3.3.4
    Line: 394

    Chances are this form uses conditional logic, and the JavaScript error is preventing the form from showing.

    Posted 7 years ago on Tuesday June 26, 2012 | Permalink
  4. You're also using a older version of WordPress. We recommend keeping up to date with WordPress upgrades as well.

    WordPress 3.3.1

    Posted 7 years ago on Tuesday June 26, 2012 | Permalink
  5. David, I retried those things and nothing helped.

    Chris, I deleted the plugin folder: gravityforms and replaced it with the folder I downloaded from your link. On the Gravity Forms Settings page it says Installation Status:
    Wordpress Version 3.4 (I had also updated that this morning earlier)
    Gravity Forms Version 1.6.4.5.4

    So I should be all updated now. However, they still aren't showing. I do have the forms using conditional logic - how do I get JavaScript to not prevent it from showing?

    Thanks!

    Posted 7 years ago on Tuesday June 26, 2012 | Permalink
  6. jQuery is being loaded in the footer. It needs to be loaded in the header for the form to be rendered properly. How did you get jQuery loaded in the footer?

    The stylesheet is also being loaded in the footer. It should be in the header as well.

    You do have the latest version installed now. Your upgrade did not go well before.

    Posted 7 years ago on Wednesday June 27, 2012 | Permalink
  7. Sorry, I have no idea how to fix the jQuery loading. Honestly, it worked brilliantly before and then with the update it doesn't work. How do I fix it?

    Posted 7 years ago on Wednesday June 27, 2012 | Permalink
  8. You will need to find some local help for your site. It can probably all be handled in the WordPress admin or maybe a template file edit.

    I'm not sure how it was working before, but I believe this is what's causing the problem now.

    Posted 7 years ago on Wednesday June 27, 2012 | Permalink
  9. I don't have any local help. I just removed the conditional logic from the form and it now shows up. Seems like this should be something your support should be able to help with. http://grantsburgdollarsforscholars.com/golfing-for-grads

    Posted 7 years ago on Wednesday June 27, 2012 | Permalink
  10. David Peralty
    Administrator

    Crosstown - The issue isn't with Gravity Forms, but with how your theme is currently set-up. In your footer.php file, do you see the call for JQuery? If so, can you move it to your header.php file somewhere before </head>?

    Posted 7 years ago on Wednesday June 27, 2012 | Permalink
  11. I opened my footer.php file and searched for the word jquery but no results. This is what I see in that file:

    <?php $hide = (biz_option('smallbiz_feature_box_disabled')); if($hide == ""){ ?>
    <ul id="featured" >
    <li class="first featured">
    <?php include(TEMPLATEPATH."/footer_left.php");?>
    
    <li class="featured">
    <?php include(TEMPLATEPATH."/footer_middle.php");?>
    
    <li class="featured">
    <?php include(TEMPLATEPATH."/footer_right.php");?>
    
    <?php } else { echo "&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"; /* Safari fix */} ?>
    </div>
    <div id="footer">
    <p class="footercenter"><?php echo biz_option('smallbiz_cities');?></p>
    <p class="footercenter">
    <?php echo biz_option('smallbiz_credit');?>
    </p>
    <div id="footer-mobile-switch">
    <?php
    $urlmd5 = md5(get_bloginfo('siteurl'));
     if(get_option('smallbiz_mobile-layout-enabled') && $_COOKIE[$urlmd5."device_type"] == "Mobile"){
     ?>
    <p>
            View site in:
            <<?php if($GLOBALS["smartphone"]){ echo "b"; } else { echo "a"; } ?> href="<?php echo get_bloginfo("wpurl"); ?>?ui=m">
               Mobile
            </<?php if($GLOBALS["smartphone"]){ echo "b"; } else { echo "a"; } ?>>
             |
            <<?php if(!$GLOBALS["smartphone"]){ echo "b"; } else { echo "a"; } ?> href="<?php echo get_bloginfo("wpurl"); ?>?ui=f">
               Desktop
            </<?php if(!$GLOBALS["smartphone"]){ echo "b"; } else { echo "a"; } ?>>
    
            </p> <!-- end site-ui-switch-link -->
            <?php
        }
    ?>
    </div>
    		</div>
    	<!-- </div> -->
    <?php wp_footer(); ?>
    </div> <!--site wrap closing-->
    </body>
    </html>
    Posted 7 years ago on Wednesday June 27, 2012 | Permalink
  12. Again, I don't get it because I haven't changed my theme. It worked before and it stopped working after I updated gravity forms. Sorry if I sound upset, this is for a client of mine and they have a fundraising push going on right now and the online part of that is not working. I talked to the theme developer and he said it's a gravity forms issue. So I'm lost!!

    Posted 7 years ago on Wednesday June 27, 2012 | Permalink
  13. David Peralty
    Administrator

    Can you send me the link and an admin level login to peralty@rocketgenius.com and I'll see if I can get it working for you? Do I also have permission to make changes to the theme file(s) if need be?

    Posted 7 years ago on Wednesday June 27, 2012 | Permalink
  14. David, I sent you log in info yesterday and hoping you received my email! I appreciate your help.

    Posted 7 years ago on Thursday June 28, 2012 | Permalink
  15. David Peralty
    Administrator

    I did, I'm going to log in now to have a look.

    Posted 7 years ago on Thursday June 28, 2012 | Permalink
  16. Crosstown: I'm also having same issue with part of the form not showing up. JQuery seems to be the issue. I'll be watching to see if this thread helps my issue as well.

    Posted 7 years ago on Saturday July 7, 2012 | Permalink
  17. David Peralty
    Administrator

    TweetPages - To fix this issue I used the enqueue JQuery script I found here:
    http://codex.wordpress.org/Function_Reference/wp_enqueue_script

    Posted 7 years ago on Saturday July 7, 2012 | Permalink
  18. Im confused as heck. I'm using the atahualpa theme on two sites... i cloned the 2nd based on the first... now the plugin for the second site isnt showing up.

    Granted, I'm using a different style for the atahualpa clone... but that shouldn't affect things... I tested it out on the thesis theme for that same domain and it ain't working either !

    the domain: whimsikill.com

    help please

    Posted 6 years ago on Thursday August 23, 2012 | Permalink
  19. by the way, the problem is only with chrome... and only in that domain and not the original: ipersonalenrichment.com

    Posted 6 years ago on Thursday August 23, 2012 | Permalink
  20. The form is showing up for me on the whimsikill site in Chrome: Screenshot

    Posted 6 years ago on Thursday August 23, 2012 | Permalink
  21. that's good news... but strange as hell as well.

    Do you know what could be causing this weirdness ?
    I'm using chrome incognito and normally... and it's not showing... and a customer told me it wasn't showing either.

    any ideas ?

    Thanks

    Posted 6 years ago on Thursday August 23, 2012 | Permalink
  22. I am having the same problem. After the update, forms not loading. If i deactivate gravity forms, everything load perfectly. It appears there is a bug in the latest release of gravity forms in my humble opinion.

    Posted 6 years ago on Friday August 24, 2012 | Permalink
  23. @dayoamon - can you provide a link to your form online please?

    After upgrading, it's usually cached javascript causing the forms not to display. With a link to your form we'll be able to help you out. Thank you.

    Posted 6 years ago on Saturday August 25, 2012 | Permalink
  24. Thanks. Take a look at the page using the following link: http://makeitnigeria.com.ng/agent/makeitnigeria/. Notice that the page did not finish loading as the footer of the site is missing from the form.

    Previously almost all pages would not load on the site. Then i had to disable a few plug-ins, especially the Contact Form 7 Plug-in before most of the forms started loading. The site worked perfectly until the last Gravity Forms update.

    Greatly appreciate your offer to help.

    Posted 6 years ago on Saturday August 25, 2012 | Permalink
  25. What is the bottom of that page SUPPOSED to look like? It looks like at some point a plugin or some function errors out, and the rest of the page is not loaded after that error. So, what should be right there at the bottom of the page?

    You can try turning on WP_DEBUG to see what errors might be causing this:
    http://codex.wordpress.org/WP_DEBUG

    Additional information on using WP_DEBUG, including logging and displaying errors:
    http://codex.wordpress.org/Debugging_in_WordPress

    Do any of the pages on the site load fine, so I can compare?

    Does the Gravity Form work fine in the Form Preview?

    Posted 6 years ago on Sunday August 26, 2012 | Permalink
  26. I had the same problem. Following David's advice to look into using the enqueue jquery script, I found reference to the plug-in 'Use Google Libraries'. Either download from here:

    http://wordpress.org/extend/plugins/use-google-libraries/

    ...or do a search from within your Wordpress admin / plugins / add new

    Once you've got this installed and up and running, go into your header.php, which is probably where you'll have jquery loading, and comment it out so that your new plug-in handles all of this instead.

    Once you do that, you should see your form again. It worked for me anyway.

    Geoff

    Posted 6 years ago on Wednesday October 24, 2012 | Permalink