PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

[resolved] Form not showing at all...checked footer...now what?

  1. Kevin Geary
    Member

    wp_footer is being called in footer.php but the form is still not showing (it has conditional logic enabled).

    I have a form on a different page with no conditional logic and it's working fine.

    Please help.

    Posted 10 years ago on Monday July 5, 2010 | Permalink
  2. Kevin Geary
    Member

    team.karate-usa.com/contact-us/ is the page it's not showing up on if that helps.

    Posted 10 years ago on Monday July 5, 2010 | Permalink
  3. The script in the footer that runs the conditional logic is being wrapped in a < p> tag when it shouldn't be. We've seen this a few times before and it's always been due to a "raw" or "noformat" shortcode that's been added to the theme to allow you to post markup without WordPress reformatting it.

    http://forum.gravityhelp.com/topic/form-worked-for-a-while-and-then-disappeared#post-6399

    If that's not something you're using, you can look in your functions file for "wpautop" - thats usually where you'll find the shortcode snippet. You can remove or comment out that section if you want.

    Alternately, we've found that wrapping the Gravity Form shortcode in the "raw" shortcode in the post editor also fix the issue.

    [raw][gravityform id=39 name=ContactMe][/raw]

    or

    [noformat][gravityform id=39 name=ContactMe][/noformat]

    UPDATE: it appears wrapping the form shortcode with the raw/norformat shortcode does NOT work in all instances. It's recommended to remove or disable the raw/noformat shortcode instead.

    Posted 10 years ago on Monday July 5, 2010 | Permalink
  4. Kevin Geary
    Member

    Thank you!

    Posted 10 years ago on Monday July 5, 2010 | Permalink

This topic has been resolved and has been closed to new replies.