PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not showing in page

  1. Hello,

    The form I created and embedded in a page does not show when I view the page.
    I only see the submit button. When I click the submit button the validation works and the form is visible and highlighted.
    Let me now where I can sent a login so you can check it.

    Thanks in advance.

    Posted 8 years ago on Wednesday July 13, 2011 | Permalink
  2. The issue is going to be something specific to either your site setup (theme conflict? plugin conflict?) or how you configured any features like conditional logic on your form. The first thing you need to do is check for plugin and theme conflicts by following the instructions here:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    If after following those instructions you aren't able to determine if a theme or plugin conflict is causing the issue, post a link to a page on your site containing a form where this is happening so we can see the page and see the issue happening so we can debug it.

    Posted 8 years ago on Wednesday July 13, 2011 | Permalink
  3. It is a theme conflict. The form is visible after activating the Twenty Ten theme.
    On the homepage I have a form in the sidebar and this one works fine.
    Does this mean that you cannot resolve this?

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  4. I have tested it also with Formidable forms and there is no conflict with the theme.

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  5. When I switch off the Output CSS the form appears. Only the formatting of the fields/labels is not correct anymore. Could it be a CSS issue?

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  6. Can you post a URL to your form page? I'm going to need to see it to help you debug your issue. It's most likely some type of styling conflict with your theme but I can't give you any direction until I see it.

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  7. Hi Kevin,

    Here is the link to the page:
    http://www.lichtdeboer.nl/contact/

    Thanks!

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  8. There's some kind of CSS conflict with your theme but I haven't nailed down the source of it just yet.

    Try adding this to the end of your theme stylesheet. It should work for you. It did in my test.

    [css]
    body .gform_wrapper ul.gform_fields {
        overflow: visible;
    }

    screenshot: http://bit.ly/p6f5Ij

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  9. Are you planning to look further into it then?
    I added the code and yes it works now ... thanks very much.
    This is a big relieve!

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  10. Yeah, I'll take another look at it and see what the initial cause was but it shouldn't be a big deal. The snippet I gave you should suffice either way to overcome whatever is causing the style conflict.

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  11. After another pass.. I'm still not sure what the origin of the display problem is. It's related to your theme somehow.

    The UL containing your form fields is being floated/pushed to the right (red border in example) outside of the viewable area of the "gform_wrapper" div (dashed green border in example). I'm not clear why, but setting the overflow to visible makes it happy.

    screenshot: http://bit.ly/pDilWQ

    Either way, you should be fine to run with what's working now.

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  12. Thanks for checking it again! I informed the developer of the theme and he will check this according to your feedback and solution in the css.

    Now I can finish my project with Gravityforms and that feels fine.

    Posted 8 years ago on Thursday July 14, 2011 | Permalink
  13. Great. Thanks for the update. Let us know if you need anything else.

    Posted 8 years ago on Thursday July 14, 2011 | Permalink

This topic has been resolved and has been closed to new replies.