PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not submitting after move to new server

  1. jeffhiggins
    Member

    Have a look at: http://aqualyseusa.com/contact-aqualyse/

    After pressing submit, the page just refreshes, and nothing is submitted or validated. This Wordpress install was just moved from another server, and I used this tool (http://interconnectit.com/124/search-and-replace-for-wordpress-databases/) to update all the URLs in the database (I found this tools recommended in another forum post here).

    I ran into this problem last night with moving another Wordpress install. I solved it by re-creating the form and the page that the form is embedded on. I'm not really in the mood to re-create this form once again, so I'm wondering if anyone can help.

    I've tried running the meta fix plugin tool, but it doesn't seem to help. I'm going to have to duplicate this Wordpress install to several other sites, so I'm going to keep running into this problem.

    Thanks!

    Posted 10 years ago on Friday May 4, 2012 | Permalink
  2. Jeff, what if you exported your forms and then import the XML files into the new sites?

    Looking at your source you have your jQuery in the footer of your site. Can you move the jQuery reference to the head of the page? A lot of Gravity Forms functionality requires that jQuery be placed before the form coding, as other scripts get called there.

    Posted 10 years ago on Friday May 4, 2012 | Permalink
  3. jeffhiggins
    Member

    Thanks for the fast reply! I just deleted all the forms from the new WP install, and exported the working form from the old WP. Same problem, unfortunately.

    New, non-working form: http://aqualyseusa.com/contact-aqualyse/
    Old, working form: http://aqualyse.co.uk/contact-us/

    Any ideas? Why isn't the new form submitting?

    Posted 10 years ago on Friday May 4, 2012 | Permalink
  4. Try the Meta Recovery Tool on the downloads page to see if that helps:
    http://www.gravityhelp.com/downloads/

    Posted 10 years ago on Friday May 4, 2012 | Permalink
  5. jeffhiggins
    Member

    Already did that, but just did it again after importing the form - no dice, it's still not submitting: http://aqualyseusa.com/contact-aqualyse/

    Posted 10 years ago on Friday May 4, 2012 | Permalink
  6. You are experiencing some sort of server problem. The form is not submitting because the server is returning a 404 error as a result of the post action.

    Gravity Forms never has a chance to process the form fields because it never gets to Gravity Forms, your server is acting as if the URL in the Post action does not exist and is returning a 404 error.

    See this screenshot:

    https://skitch.com/carlhancock/82bys/contact-aqualyse-by-procare

    This is unusual because Gravity Forms submits to the same page that the form is embedded on. If you view source on the page and look for the form action that Gravity Forms uses you'll see it's the same relative path as the page the form is being displayed on.

    For example, your form is displayed here:

    http://aqualyseusa.com/contact-aqualyse/

    The form action is using a relative path and it is:
    /contact-aqualyse/

    Your server is acting like the page does not exist despite the fact you are looking at it.

    This could be a URL permalink issue related to how the server is doing URL rewriting. Either way it is an issue being caused by your server and is not a bug or problem in Gravity Forms itself.

    What you are going to need to do is discuss this with your web host. Explain to them what I described above and show them the screenshot that I provided them.

    Posted 10 years ago on Friday May 4, 2012 | Permalink
  7. jeffhiggins
    Member

    Ok, I'll contact Godaddy - thanks Carl and Rob!

    Posted 10 years ago on Friday May 4, 2012 | Permalink
  8. jeffhiggins
    Member

    Some followup - I contacted my webhost (GoDaddy) but got a fairly nonsense reply (surprising!). I did some poking around on my own, and I was able to get the form working by changing the permalink structure. Just thought I'd share this info in case it comes up elsewhere. I assume this is a byproduct of moving the Wordpress to a different server/URL.

    One weird thing though - after changing the permalink structure, I changed the "stub" of the page my form is embedded on. It was "contact-aqualyse", but I wanted it to be just "contact". After doing this, the form stopped working again (same problem - it wouldn't submit or validate, just reload with the 404 happening in the network inspector). After changing the stub to "contact-us" the form started working again. I'm just happy it's working, but any idea why the form doesn't like that particular stub name?

    Posted 10 years ago on Monday May 7, 2012 | Permalink