PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not submitting email, and no confirmation

  1. Nick

    Hi team,

    This WAS working but somehow I've messed something up. I've also followed the advice here:

    My form looks great, but it's not sending emails, it's not redirecting to a confirmation page (tried text, page and redirect).

    It's also doing something strange with the contact form page AFTER hitting submit. Probably easier to just take a look at the test page: (identical copy of what I was trying to make happen live - this page is currently hidden).

    The result looks very different in Chrome vs IE vs Firefox.

    I'm using the very latest update, but the problem existed before 1.6.9. I've tested this with the Twenty Ten theme, I've deactivated all plugins. The only active plugin is WP-Hive which I can't deactivate without destroying the site. Gravity and WPHive worked fine together before, and neither had any updates.

    It WAS working, and in the past I'd used a custom PHP mail plugin, but I managed to get this working without it sending through my Gmail SMTP server.

    I'm confident I've inadvertently created some sort of conflict, somehow. Please help!

    Nick in New Zealand

    Posted 9 years ago on Wednesday October 24, 2012 | Permalink
  2. Since we can't make many changes to this live site, can you export the form as XML and email it to me at ? I can install it and see if it's a problem with the form or with Gravity Forms 1.6.9 or if it works fine for me. I would guess it's a theme or plugin conflict, but without being able to follow all the steps here we're going to be guessing.

    Posted 9 years ago on Thursday October 25, 2012 | Permalink
  3. I just found something very strange. This URL returns a 404 error. The page loads just fine, but if you check the headers. you will see that the status code is 404 rather than 200. I think that is your problem. I'm not sure what's causing that.

    Can you try refreshing your permalinks (visit the permalink setting page and just save them again as is)? Or, try without pretty permalinks at all.

    Posted 9 years ago on Thursday October 25, 2012 | Permalink
  4. Nick

    I've disabled the form - the test page I've supplied the URL to is really just for testing. We can edit, modify, whatever you need. My LIVE contact page has just a simple old fashioned email link for now, and to be honest this site is new enough that there's not much traffic - I can afford to lose a few visitors if something's not right while we test. I've also decided this is more important, and have removed the pages that would be affected by the other active plugins and deactivated them.

    So now the ONLY active plugins are obviously Gravity Forms and WP Hive, which I can't deactivate without the entire site vanishing. I'm confident it's not causing the problem as it's been there forever, back when this form and this theme DID work.

    I've tried the permalink trick too already. It was one of the first things I did as your team recommended for another glitch I was experiencing, although I didn't try to disable them totally. Point is this form WAS working, then just stopped. All I've done is add a few pages.

    Posted 9 years ago on Thursday October 25, 2012 | Permalink
  5. Nick

    The 404 error is interesting. I'll talk to the Elegant Themes people about it because EVERY page (other than index) is giving that error.

    Nothing's changed though - this WAS working with this theme until recently. I'm sure we'll fix this, it's not a GF fault, it's just something I've done.

    Posted 9 years ago on Thursday October 25, 2012 | Permalink
  6. That used to happen with bbPress many years ago. The page would display fine but would really be returning a 404 error code. You never suspect anything is wrong until something like this happens.

    Let us know what you find out when you resolve this. If you need additional help, please let us know.

    Posted 9 years ago on Thursday October 25, 2012 | Permalink
  7. Nick

    I deactivated everything including GF and WPHive, I've switched to the Twenty Ten default theme, I've reset the permalinks, I've re-installed the Wordpress files.

    Something in all that has fixed both the 404 error and the GF issue. I've moved back to my custom theme, still working.

    Magic? Or ghosts? LOL

    Than ks for your help anyway Chris.

    Nick in New Zealand

    Posted 9 years ago on Thursday October 25, 2012 | Permalink
  8. That's good news. Glad it's working for you now.

    Posted 9 years ago on Thursday October 25, 2012 | Permalink

This topic has been resolved and has been closed to new replies.