PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form suddenly doesn't display!

  1. tangocharlie
    Member

    Hi there,

    I created a form with conditional logic for a wedding RSVP and periodically tested that it was progressing as I expected, and everything was working well. All the fields worked as I expected and I was able to play around to my hearts content. Until a submitted a test entry. I got the email, but now when I navigate to the page that the form is on, I get a blank page. I can see that form is there on the page but is set to display none and that there's a JavaScript error relating to the processing of conditional logic:

    Uncaught ReferenceError: gformIsNumeric is not defined
    - gf_try_convert_floatconditional_logic.js:89
    - gf_matches_operationconditional_logic.js:111
    - gf_is_matchconditional_logic.js:79
    - gf_get_field_actionconditional_logic.js:45
    - gf_apply_field_ruleconditional_logic.js:22
    - gf_apply_rules

    But I have no idea what it means and how it suddenly got broken!

    Can anyone tell me how I can fix this and why it might have suddenly stopped working?!

    If it helps, I'm using the "Super Skeleton WP" theme, which actually recommended GravityForms in the documentation.

    update:
    It's definitely a problem with the conditional logic, if I take that all out, it works fine. It seems to be a problem with me using a "greater than" operator on a dropdown field which has "1", "2", "3", etc as values. I've tried also enable values and putting numbers in there but that makes no difference.

    Cheers,

    Tom

    Posted 9 years ago on Saturday February 25, 2012 | Permalink
  2. Does the conditional logic work when you look at the form in Preview mode through the form builder?

    Posted 9 years ago on Saturday February 25, 2012 | Permalink
  3. tangocharlie
    Member

    Actually, the form preview seems to be completely broken on my site. Nothing displays at all and looking at the HTML generated there's no sign of the form.

    I worked out what the problem was with my form though, and also a workaround. I had a dropdown list of options with the text "1","2","3" etc. and was using conditional logic to only display certain fields when the dropdown was "greater than 1" or "greater than 2". I think there's a genuine bug there where it tries to cast the string value from the dropdown to a number for the purposes of evaluating the conditional logic. To get around this I changed the logic to from this form: "greater than 3" to this form: "is not 1 AND is not 2 AND is not 3". It's a tiny bit more hassle, but at least my from displays.

    Posted 9 years ago on Saturday February 25, 2012 | Permalink
  4. I'm having the same problem when I try to use "greater than" in a conditional logic field.

    Posted 9 years ago on Sunday February 26, 2012 | Permalink
  5. Just to confirm, same issue with a less than conditional rule in both the preview and published form

    Posted 9 years ago on Thursday March 1, 2012 | Permalink
  6. Me too, same Problem.

    Unfortunately the solution to manually add more conditions (is not 1, is not 2 ....) is for me not an option.

    I' ve a form where user need to register up to 20 Athletes for a Sport Competition (Dropdown from 14 to 20). For every Athelt there are additional fields for first name, last name, age, weight, birthday and so on.
    If i have to do all manually it will take to much hours.

    Please fix the bug as soon as possible.

    Thanks

    Great tool by the way

    Posted 9 years ago on Monday March 12, 2012 | Permalink
  7. I am having the same problem

    Conditional logic forms are not showing in the preview and are also not showing in the theme. I closed down the plug in and no change. Then I changed the theme to 2011 and it works.
    I am also using Super Skeleton when I swap out the theme to check for a conflict everything works fine. However when using super skeleton (which recommends gravity forms) nothing shows.

    I put up a test form at http://www.bodegacity.com/2012/06/07/que-pasa-events/

    Please let me know what to do.

    Kindest

    Jack

    Posted 9 years ago on Sunday June 10, 2012 | Permalink
  8. Same issue. Only since the update to 1.6.4.5.

    This FAQ answer did not solve the issue:
    http://www.gravityhelp.com/question/why-is-there-a-style-attribute-of-displaynone-being-added-my-form-isnt-showing-up/

    Can we download the previous version?

    Posted 9 years ago on Sunday June 10, 2012 | Permalink
  9. Rob, please being a new topic for your issue with a link to your website and we'll be happy to help you there. Thanks.

    Posted 9 years ago on Monday June 11, 2012 | Permalink

This topic has been resolved and has been closed to new replies.