PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form would not save

  1. guevara
    Member

    I have a form which saved b4 but it aint saving now just says - Saving form. Please wait...

    Posted 8 years ago on Wednesday March 23, 2011 | Permalink
  2. Is this when you submit a form or when you try and save a form in the Form Editor?

    Posted 8 years ago on Wednesday March 23, 2011 | Permalink
  3. guevara
    Member

    Save in the form editor - it saves for a few steps but when i edit a bit more it stops saving

    Posted 8 years ago on Wednesday March 23, 2011 | Permalink
  4. This sounds like it could be a PHP memory issue. I would suggest increasing your available PHP memory. If it works on really short forms, but quits working on longer forms that is because the AJAX is unable to complete because there isn't enough PHP memory. A lot of shared hosts default to a very low amount of PHP memory but it can be increased.

    Here is an article on how to increase your available PHP memory:

    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    Posted 8 years ago on Wednesday March 23, 2011 | Permalink
  5. guevara
    Member

    I tried that but it aint working

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  6. gfgirl
    Member

    I'm having the same issue. I have define('WP_MEMORY_LIMIT', '256M'); in wp-config.php and I'm still getting the same message - "Saving form. Please wait..."

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  7. worldccc
    Member

    I am having the same issue, even after changing my memory limit.

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  8. guevara
    Member

    Any suggestions Carl?

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  9. @gfgirl Simply adding the memory limit in wp-config.php doesn't always increase your memory, sometimes you have to update your .htaccess or php.ini file. See this article: http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    @worldccc See above, make sure your memory actually was increased. There are plugins you can install from WordPress.org that will display what your available memory is to be sure.

    @guevara Send us a WordPress admin login for this site via our Contact Us form and reference this post when doing so and we'll take a look.

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  10. joethoron
    Member

    I've been having a similar problem intermittently.

    It appears to affect some field types but not others. For example, I can add text fields, number fields, and paragraph fields, but a checkbox field kills the form. It says, "Saving form, please wait..." forever. If I click away an "ajax error" pops up on the page.

    Frustrating.

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  11. joethoron
    Member

    Same with multiple choice.

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  12. gfgirl
    Member

    I submitted my issue through the Priority Support contact form with an admin login for you. Thank you.

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  13. @joethoron That is a MOD_SECURITY issue. Your MOD_SECURITY settings are blocking the AJAX request because it thinks it's a malicious attack. See this forum post, it outlines the fix and you may need to get in touch with your web host to implement it:

    http://www.gravityhelp.com/forums/topic/forms-not-updating-after-being-saved#post-10305

    @gfgirl Thanks, we'll take a look and get back with you soon.

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  14. @gfgirl Your issue is the same as @joethoron's. It's a MOD_SECURITY issue. Your MOD_SECURITY settings are blocking the AJAX request because it thinks it's a malicious attack. See this forum post, it outlines the fix and you may need to get in touch with your web host to implement it:

    http://www.gravityhelp.com/forums/topic/forms-not-updating-after-being-saved#post-10305

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  15. gfgirl
    Member

    Carl, thank you! I whitelisted the admin-ajax.php file in apache & I'm able to edit forms now.

    Thank you! :)
    Eve

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  16. joethoron
    Member

    Cool. Thanks for identifying that. It's been making me nutty but I haven't come into the forums to ask for help.

    Posted 8 years ago on Thursday March 24, 2011 | Permalink
  17. guevara
    Member

    I have sent my log deatiails via contact us form, thanks in anticipation

    Posted 8 years ago on Friday March 25, 2011 | Permalink
  18. @guevara If your issue is indeed the MOD_SECURITY issue the only solution is the only one you approached your host about. That is the only solution. If MOD_SECURITY is blocking the ajax request to that file, there is nothing we can do to resolve that. It's a web server firewall issue.

    Your host is being overly paranoid. Plenty of users on the forum have had the same issue and updated their MOD_SECURITY settings to whitelist that file. They don't whitelist your entire server, just that single file. We have code in place on our end to prevent injection and malicious attacks using that file.

    So whitelisting that file is not going to open up your site to hacks. But not whitelisting that file means Gravity Forms isn't going to work because the AJAX can't function properly.

    Posted 8 years ago on Friday March 25, 2011 | Permalink
  19. Im having similar issues, I have a large form which won't update.

    I get this message:
    "There was an error while saving your form, most likely caused by a plugin conflict. Please contact us and we will be happy to help you get this corrected."

    However, other forms save fine (not as large).

    I have been in touch with my host and they state that they don't use MOD_SECURITY.

    I'm a bit stuck!

    Posted 8 years ago on Thursday June 9, 2011 | Permalink
  20. It turns out I had a link in a custom html block. When I removed the tag and its contents it worked perfectly.

    I also noticed that when you enclose anything in " (basically a link) it breaks the form saving process.

    Posted 8 years ago on Thursday June 9, 2011 | Permalink
  21. @Tom Tong what field type were you using?

    Posted 8 years ago on Thursday June 9, 2011 | Permalink
  22. ASMBS IT
    Member

    Seems all remedies here focus on server side issues. However, I cannot create, edit nor save a form. I get the error "Ajax error saving form". The kicker is I am 1 of 3 people with access. We are all on the same network. 2 people have no problems. I get the error every time. Seems specific to my machine. I am running Windows 7 Ultimate. I have updated everything and have tried using Chrome, IE9 and FireFox. I get the same error in all browsers. I have not encountered any problems with any other sites with ajax applications. Is there a possible solution out there? These forums have been no help at all. Still waiting on a response from the "Priority Support".

    Posted 7 years ago on Thursday September 1, 2011 | Permalink