PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Formatting Not Showing Up

  1. Everything looks great in the preview of the form, but on the site, most of the formatting is getting stripped out (and I'm not sure how to fix it). I assume that the theme is somehow interferring. Can CSS classes be used to straighten this out? If so, where do I start?

    The name element, which looks really good the way it is originally formatted, displays here with four text boxes of all the same width (which makes no sense) or spacing between the elements. The address box displays the same way.

    Here is the link to the form: http://realcsr.com/join-now/

    Thanks for the help in advance.

    Brent

    Posted 10 years ago on Sunday October 16, 2011 | Permalink
  2. You're missing the stylesheet and scripts for Gravity Forms. How did you embed the form in that page? If you used the PHP function call directly, you will need to include the scripts and styles yourself. http://www.gravityhelp.com/documentation/page/Gravity_form_enqueue_scripts

    Note this is only necessary when you are NOT using the shortcode to insert the form into a page or post.

    If you are using the shortcode and the form looks like this, then your theme might be missing the wp_head or wp_footer call.

    Try the default Twenty Eleven theme and see if things work properly there. If they do, you have a problem with the theme and need to resolve that.

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 10 years ago on Sunday October 16, 2011 | Permalink
  3. I used the button in the WP editor to embed the form in the page. This is the code it inserted: [gravityform id=2 name=JOINUS - Please Submit the Following Information].

    I tried to view the same page in the Twenty Eleven 1.2 theme--and I'm having the same problem. Does that still mean that I'm having a problem with the wp_head or wp_footer call? (but that seems unlikely, given that it doesn't seem to be theme-related).

    Here's a link to the page in Twenty Eleven 1.2: http://realcsr.com/join-now/.

    Brent

    Posted 10 years ago on Sunday October 16, 2011 | Permalink
  4. It could be from a plugin conflict as well.

    If you used the button in the post editor to embed the form, you don't need to enqueue anything manually.

    It's unlikely to be a problem with the call to wp_head or wp_footer with the default theme.

    I would try to find out if this is a plugin conflict by following the troubleshooting tips here:
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    If you have the same problem with the default theme and no plugins active, there is definitely something strange going on. It's not a problem that happens very frequently.

    Posted 10 years ago on Sunday October 16, 2011 | Permalink
  5. I followed the link in your previous response and then followed the procedures. The problem persists in different themes (including Twenty Eleven). I also deactivated all the plugins on the site, then reactivated the Gravity Forms plugin, and the problem still persists.

    This is a link to the page (with the original theme installed, but with all plugins deactivated, except for Gravity Forms): http://realcsr.com/join-now/.

    I'm still having the same problem.

    Posted 10 years ago on Sunday October 16, 2011 | Permalink
  6. Check your form settings and confirm that you have the "output CSS" option enabled. That could be the reason your default form styles aren't being loaded.

    Posted 10 years ago on Sunday October 16, 2011 | Permalink
  7. Sometimes it's the silliest thing. . . Nice call. It's working fine now.

    Posted 10 years ago on Sunday October 16, 2011 | Permalink
  8. Wonderful. Glad it was a simple thing. It's something that just happens sometimes.

    Posted 10 years ago on Sunday October 16, 2011 | Permalink

This topic has been resolved and has been closed to new replies.