PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Forms freeze during creation process

  1. BrettBorders77
    Member

    I am running into a chronic problem that I need to resolve ASAP. I'm out of business - no clients can contact me. GravityForms does not work and cannot be edited. During the process of setting up or editing the first form - it will freeze up and I will be unable to continue editing the form.

    I'm running:
    PHP Version 5.2.14
    MySQL Version 5.1.55
    WordPress Version 3.2
    Gravity Forms Version 1.5.2.8

    Thesis theme 1.8.

    To diagnose:
    I have uninstalled GF, wiped it off my FTP, re-installed the latest version, updated to the latest version or WP, tried the older version of GF (1.5.2.2) - I have disabled ALL plugins and tried it again so I don't want to hear how it must be some kind of plugin issue. I have cleared my Cache from w3 Cache and Cloudflare.. turned these services off or into Development mode.. and tried it again.

    I have tried it no less than 15 times with different settings and precautions each time.

    Here are pics of what happens every time:

    https://skitch.com/brettborders/fj87h/shared-menubar
    https://skitch.com/brettborders/fj86k/shared-menubar

    It will always work for a minuite or two... part way into setting up the form.. then it freezes.

    Gravity Forms works fine on my other installations of Wordpress on the same webhost... but it doesn't work on my main site, running same version of WP.

    I used to work on my main site... but it doesn't any more... after re-installing WordPress something seems to have changed.

    I need to fix this ASAP! What can I do?

    and if you can't troubleshoot via form, where can I send my login / FTP details for a GF developer to get it working?

    -Brett

    Posted 7 years ago on Monday July 11, 2011 | Permalink
  2. You shouldn't be seeing code. Something is either wrong with your plugin files, or wrong with your core WordPress installation. Code shouldn't be displayed like that, the PHP should be executed so something is really wrong with your site. It's also possible it's a plugin or theme conflict that is causing this issue. I would suggest testing for plugin and theme conflicts by following the instructions here:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Gravity Forms doesn't do what is in those screenshots and we've never seen this behavior, so something is definitely wrong with your WordPress installation. Hopefully it's just a theme or plugin conflict, otherwise it looks like something wrong with your WordPress install itself.

    Posted 7 years ago on Monday July 11, 2011 | Permalink
  3. BrettBorders77
    Member

    Everything works beautifully except Gravity Forms. Wordpress is singing along like a hummingbird and does not have any issues or bad behaviors. I am running the newest version of Wordpress and the newest version of Thesis. Very garden grade stuff here.

    So I have no problems with Wordpress - and no problems with any other plugins - just Gravity Forms.

    ALL plugins were disabled when this screenshot was taken.

    It doesn't seem to be a plugin conflict.

    All code works except GF.

    What are the next steps I should take in terms or troubleshooting or getting a refund?

    -Brett

    Posted 7 years ago on Monday July 11, 2011 | Permalink
  4. There is nothing wrong with the Gravity Forms code and nobody else is reporting this issue as you can see by browsing the support forum, and from you yourself saying it's working fine on other sites you have. So the issue is specific to your site which means something is wrong with your site that is causing the problem with Gravity Forms.

    Just because other plugins work fine doesn't mean another plugin could be causing a conflict. Many poorly written plugins appear to work perfectly fine while they cause problems for other code within WordPress.

    The first step is following the instructions in the conflict resolution test I linked to above. That is the first step in any conflict resolution test. You mentioned you disabled plugins, but you didn't mention your theme. Part of the conflict resolution test is following all the steps, including testing for theme conflicts. I'm not aware of any with Thesis, but then again we can't control any customizations you may have in place for Thesis. We only test against Thesis out of the box with no customizations.

    After you perform the conflict resolution test, which it doesn't sound like you did based on your reply above, let me know how it goes. If you can't determine the problem we can take a look at it. We would need logins in order to do so.

    Posted 7 years ago on Monday July 11, 2011 | Permalink
  5. BrettBorders77
    Member

    By some odd miracle.. after the 17th or 18th flush.. reinstall, re-try, plugin disable, theme change check... it seems to work.

    I will keep my fingers crossed.

    Posted 7 years ago on Monday July 11, 2011 | Permalink
  6. It's sounds like it could be a caching issue of some sort. You mentioned W3 Total Cache as well as Cloudflare. I'm not familiar with Cloudflare, but it appears it does something with the traffic to speed things up, etc. It was likely related to one of those 2 things. Caching can cause strange issues to occur if the caching doesn't execute properly. With W3 Total Cache, deactivating the plugin doesn't always turn off the caching either because of how it changes physical files, etc.

    Posted 7 years ago on Monday July 11, 2011 | Permalink
  7. I am having a similar issue. I am not seeing code, but the form does freeze and I cannot edit the form. I tried to trouble shoot using the 2010 and 2011 bases themes and uninstalling and reinstalling. I have made a screenr view of this. (I have paid for Gravity form -- as I am logged in --but this is a test website that I am trying to build on before registering this form and publishing the site.

    http://www.screenr.com/UmSs

    Posted 7 years ago on Friday July 22, 2011 | Permalink
  8. I made one more screenr-cast of when I go to edit the from properties, it does show the drop down, but not the tabs per say. And even then, I cannot edit any other fields.
    http://www.screenr.com/hmSs

    Posted 7 years ago on Friday July 22, 2011 | Permalink
  9. @LaurenScruggs You mentioned you tried testing with the default WordPress themes activated, which is a good debug method, but another thing you need to test is deactivating ALL other plugins and then seeing if the form editor works properly.

    Plugins can cause problems just like Themes, by outputting Javascript where it not be output and breaking functionality in the process. So I would suggest first testing by deactivating ALL other plugins and seeing if it works. If it does work, then activate each plugin one by one and test after each one until you find the plugin that causes the issue to start happening.

    Let me know how it goes.

    Posted 7 years ago on Friday July 22, 2011 | Permalink
  10. In minute 1:45 of the first screenr I show you that I did deactivate all of the plugins, and reactivated the gravity forms -- and still had the same issues.

    Any other ideas? Why would the forms be freezing? I have not changed anything to my Wordpress backend as far as the structure or code. (I'm not smart enough for that.)

    Thanks!
    Josh

    Posted 7 years ago on Monday July 25, 2011 | Permalink
  11. I thought that maybe I needed to update to the newest plugin version, so I did that and I have the same errors -- I see that the error begins to occur when I go to make a new form and add an item with multiple options, like a dropdown or checkboxes.

    Also with the new version, it will not let em save the form telling me that it won't allow it, possibly due to a plugin conflict. Any ideas?

    Posted 7 years ago on Monday July 25, 2011 | Permalink
  12. @LaurenScruggs Send us a WordPress admin login for the site and describe the issue again via our Contact Us form and we can take a look and see what is going on. We'd have to see the issue firsthand in order to debug it.

    Posted 7 years ago on Monday July 25, 2011 | Permalink
  13. dinamoxx
    Member

    Carl, I am having the same issue.
    If you find a solution for this, please post it so that we all can fixe the problem.
    Thanks in advance.

    Posted 7 years ago on Tuesday July 26, 2011 | Permalink
  14. dinamoxx
    Member

    Carl, after several tests, I've confirmed what @LaurenScruggs said before: "forms freeze after adding an item with multiple options".

    I've tried with "Dropdown", with "Multiple Choice" and with "Checkboxes" and the result was always the same.

    I think this is an important point to take into account in order to resolve this matter.

    We will be looking forward to hearing from you.

    Posted 7 years ago on Tuesday July 26, 2011 | Permalink
  15. @dinamoxx I'm running the latest version of WordPress (v3.2.1) and the latest version of Gravity Forms (v1.5.2.8) without any issues. I have no problems adding any fields, no matter the field type and this issue isn't being reported by anyone but the users in this thread so it isn't widespread. The issue is site specific, something specific with your sites. I'm unable to replicate it on my local machine, or on 2 of my test installs on different web hosts.

    In order to look into the issue we would need to do so on your site just as we explained to @LaurenScruggs above. Send us a WordPress admin login for the site having the issue to us via our Contact Us form and describe the issue in detail and we can take a look and debug the problem.

    Posted 7 years ago on Tuesday July 26, 2011 | Permalink
  16. dinamoxx
    Member

    Carl, first of all, I want to thank you for your support.

    With reference to the "freeze" issue, I'm afraid that this is not site specific.

    Yesterday, we created two virtual machines in our bitnami account with only WordPress (v3.2.1) and Gravity Forms (v1.5.2.8). There was no other plugin installed. Just WP and GF. Anyhow, the problem was replicated in both machines.

    In order to confirm that it has nothing to do with bitnami servers, we installed WordPress and Gravity Forms (same versions than above) in a local machine, yet the issue happened again.

    Today, we've run the GF editor in Firefox, Google Chrome and IExplorer from different machines but unfurtonately nothing's changed...and, by the way, we have also discovered that in IE, when you press "Bulk Add / Predefined Choices" and choose any category, a popup always appears saying: "Are you sure you want to leave this page? You have unsaved changes. OK or Cancel". It may be something wrong there.

    Finally, we have confirmed that the problem occurs not only when you add a multiple option field but also whe you save a form and then try to continue editing it.

    Thank you very much for your help, and if you still want it, we could send our WordPress admin login to you via your Contact Us form so that you can take a look and debug the problem.

    Regards.

    Posted 7 years ago on Wednesday July 27, 2011 | Permalink
  17. @dinamoxx - the only thing unchanged is the server you've tested on, correct? Do you have the ability to test this on a different server with possibly server configuration? This is not a commonly reported issue.

    Also, regarding the "Are you sure you want to leave this page" message, please see this:
    http://www.gravityhelp.com/forums/topic/cannot-edit-form-field-without-ie-warning#post-30924

    You can post a message there for a fix from David Smith regarding this issue.

    Posted 7 years ago on Wednesday July 27, 2011 | Permalink
  18. @dinamoxx As I mentioned, there has to be something else going on here. I've already mentioned i'm running a clean install of WordPress 3.2.1 and Gravity Forms v1.5.2.8 on a local machine without any issues and nobody other than those in this thread are having this issue so it is something going on and something specific to the sites having the issue.

    This can include server configuration and settings, not just WordPress settings (themes/plugins).

    If there was user wide issue with Gravity Forms v1.5.2.8 and WordPress 3.2.1 our forum would be getting slammed with users because the majority of our users stay up to date with both the latest version of Gravity Forms and the latest version of WordPress. But this is the only thread about this issue.

    As I mentioned above, the only way to look into this issue without being able to replicate it locally is on a site that is experiencing it. If you send us a WordPress admin login and an FTP login for a site experiencing this issue via our Contact Us form (and reference this forum post) we'd be glad to take a look and debug the issue.

    Posted 7 years ago on Wednesday July 27, 2011 | Permalink
  19. It seems to be isolated on my install to the following circumstances.
    1. If I create a form, I can add the multi select and drop down form objects
    2. If I save the form and come back to edit it, then I get stuck in the "Saving Form" loop until I remove all of the multi choice or drop down elements.

    Latest wordpress, latest gravity forms. Liquid web is my host but I have applied all apache whitelists for the correct functionality on gravity forms.

    The workaround is to create your form at one sitting if you need to use the drop down or multi choice form objects (At least for me)

    Posted 7 years ago on Wednesday August 3, 2011 | Permalink
  20. @Sinschild This is going to be either a PHP Memory issue or a mod_security issue. Are you familiar with how to use FireBug for FireFox? If so use that to see what errors appear. That can help determine if the AJAX request returns an error.

    Posted 7 years ago on Wednesday August 3, 2011 | Permalink
  21. Hi. I can confirm.. same issue here..frozen on new or edit form.

    any clue ?

    Posted 7 years ago on Thursday September 29, 2011 | Permalink
  22. @kubante See our responses above. This issue is going to be a web server issue. The AJAX request is not being allowed to process. It could either be a mod_security issue, a PHP memory issue or some sort of web server configuration problem that is rejecting the AJAX request.

    To determine if it's a mod_security firewall issue what you need to do is create a New Form and ONLY add a Single Input field to it and then save the form. If it saves correctly, then continue editing and add another Single Input Field and save the form again and then choose continue editing. Now add a Drop Down field to the form and try saving it. If it doesn't save after adding the Drop Down field then it is a mod_security firewall issue. You will need to contact your web host to have them whitelist the Gravity Forms plugin.

    If it doesn't save even when only adding a Single Input field then it could be a PHP memory issue. You will need to increase your available PHP Memory and then test again. Here is a tutorial on how to do that:

    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    Let us know how it goes. But post a new forum request when you do, users need to post their own unique requests rather than piggybacking off of old forum threads as not issues are the same even if they appear to be at first glance.

    If the above doesn't fix the issue and you post a new request, please be sure to describe the issue in detail and explain what troubleshooting steps you have already done.

    Posted 7 years ago on Thursday September 29, 2011 | Permalink

This topic has been resolved and has been closed to new replies.