PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Forms inactive after update to 1.7.1

  1. We run a WordPress Network, with Gravityforms.
    Just updated today to 1.7.1.
    But all forms are shown as : "Form not found". When we go to the Gravity Forms admin of a site, the forms for that site will work again.
    But we host over 60 sites, so to visit 60 admin panels it's quite a heavy work. Anyone a fix?

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  2. David Peralty
    Administrator

    How were you updating these sites? Are you using the latest version of WordPress? Is it a Multisite network?

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  3. We updated the plugin via the Network updater and we have the latest version of WordPress.

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  4. David Peralty
    Administrator

    So it is a Multisite installation? Are you using any third party add-ons for Gravity Forms? Running any Caching plugins?

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  5. I have the exact same issue. Do these sites run on apache or nginx?

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  6. Same problem here.

    Logged in as Network Admin, updated Gravity Forms plugin, then did Update Network. Now sites say "Oops! We could not locate your form.". Re-ran Update Network a couple more times with no luck.

    Weird thing is just logging into each individual sites wp-admin areas seems to fix. Specifically if I reload the page with the missing form error after logging into the individual sites wp-admin area and doing nothing else the form then appears as expected. I previously tried clearing my cache and shift-reloading and such.

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  7. haley
    Member

    We have the same issue after doing a network upgrade to 1.7.1 upgrade.

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  8. Yes, we run on apache, and a WordPress Network...
    Oke, we will send a support ticket, but I cannot garantee that we can leave up a site with the error. I'll do my best.

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  9. If anyone here in this thread can provide us with a WP Super Admin login and FTP Access to the network so we can try to troubleshoot this issue it would be most appreciated. Please fill out a priority support form and reference this post. If you could leave at least one site "as-is" with the issue that would be ideal.

    http://www.gravityhelp.com/priority-support/

    We'll leave this thread open so we can post findings/resolutions for everyone else.

    Posted 6 years ago on Friday April 26, 2013 | Permalink
  10. I'm having this issue on 1 site that I maintain. No caching is installed as a plugin (without a doubt) or on the server (that I know of - it's on a LiquidWeb VPS)

    The domain is http://www.pivotpointsecurity.com/

    Posted 6 years ago on Friday April 26, 2013 | Permalink
  11. Is there somewhere to download previous versions?

    I could probably help test by activating 1.7.0 on a couple parked domains then upgrading (to 1.7.2 now) and trying to reproduce.

    fyi - upgrading from 1.7.1 to 1.7.2 did not reproduce the errors for me. I had previously fixed the errors after updating to 1.7.1 by logging into each domains wp-admin area separately, which took a while. Just logging in that way seemed to refresh the tables or something.

    Posted 6 years ago on Friday April 26, 2013 | Permalink
  12. anything
    Member

    I updated to 1.7.1 (or it may be 1.7.2 on some sites not sure) and got "Oops! We could not locate your form." I use WP Super Cache (may not be relevant).

    If I save the post with the shortcode in it, the form reappears.

    Posted 6 years ago on Friday April 26, 2013 | Permalink
  13. Same thing happens to me - by replacing the shortcode it works. However, on other sites I updated, it went smooth and didn't need new shortcodes.

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  14. My forms are not showing on my website after update Gravity Forms. On WP Admin, says "Form not found." Does anyone know how I can restore my forms?

    I checked and I have 1.7.2. No forms working.

    Messgaes such as:
    Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964 Warning: Invalid argument supplied for foreach() in D:\HostingSpaces\videoguy\videobenefitsguy.com\wwwroot\wp-content\plugins\gravityforms\forms_model.php on line 2964

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  15. Also having this issue "Oops! We could not locate your form." when trying to publish a new page with the Form shortcode. I never recall having to manually "Make the form active" before, nonetheless, I did that on the Forms listing page, and still no form display. I also disabled WP Super Cache and that had no obvious effect. This applies to a new form I just created.

    Single install on a standalone WordPress site. Developers license.
    PHP Version 5.3.24
    MySQL Version 5.1.68
    WordPress Version 3.5.1
    Gravity Forms Version 1.7.2

    LMK if you still want admin access - I can send you that. Thanks for your help!

    UPDATE: Older forms are working on sites I have updated. The "Oops can't be found" error affects only two NEW forms I just created today after updating to 1.7.2 in case that helps.

    Aloha, Roxanne

    Posted 6 years ago on Tuesday April 30, 2013 | Permalink
  16. Also having this issue on a multisite. Just logging into the dashboard fixes it though.
    It's a pain that I now have to log into every site to get the forms to work.

    Posted 6 years ago on Tuesday April 30, 2013 | Permalink
  17. I finally found my error. It was a plugin conflict. So I have deactivated that plugin. Does anyone remember Textile? We used to love it (our site was built in 2004 - the dark ages of WordPress) so now I wil have a bunch of funky links on old posts but who is reading them anyway?

    I can no longer find the TextileWrapper plugin in the repository, so I guess that is the good news. :-)

    Aloha, Roxanne

    Posted 6 years ago on Wednesday May 1, 2013 | Permalink
  18. wordpressuser
    Member

    c'mon awesome gf people, please give us a repository for downloading old versions!

    Posted 6 years ago on Wednesday May 1, 2013 | Permalink
  19. I don't have any plugins on this site that I don't on others where the update is working, but maybe there is a lingering conflict in the database?

    Posted 6 years ago on Wednesday May 1, 2013 | Permalink
  20. I deactivated all plug-ins and still have no form functionality. Totally messed up. Here's one of my pages where a form should be: http://videobenefitsguy.com/contactconnect/

    Signed, helpless :-(

    Posted 6 years ago on Wednesday May 1, 2013 | Permalink
  21. Hi, I also just updated to 1.7.2 and now my forms will not show up. I am getting this error on some pages: Warning: Invalid argument supplied for foreach() in /****/*****/public_html_fcmod/wp-content/plugins/gravityforms/forms_model.php on line 2964

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  22. David Peralty
    Administrator

    tburton1004 - please go through our troubleshooting steps linked to above, and please link to your form so we can see it in action.

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  23. David,
    One of my forms is located on this page: http://www.fcmod.org/about-the-museum/e-mail-newsletter-sign-up/
    I also do not see any troubleshooting steps linked. Thanks.

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  24. David Peralty
    Administrator

    Here you are - http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Sorry about that.

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  25. David Peralty
    Administrator

    Can you preview your form? Can you try creating another form as a test and seeing if it works? You didn't move your site recently from one server to another, did you?

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  26. I cannot preview my form, when I open it up to try and edit it OR create a new form, it says that there are no fields in the form, and when I try to save a newly created form the fields dissapear. Nothing else about the site has been changed recently other than updating this plugin and a couple of others. I will try the troubleshooting steps next.

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  27. I just tried activating the default twenty ten theme, and also deactivating all plugins, neither solution seemed to bring my forms back.

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  28. David Peralty
    Administrator

    Can you try out Meta Recovery Plugin on our Download Gravity Forms page that can be found over to the right? This, when installed, will add a new sub-menu to Forms. Try using it to get your forms working again. Please make sure you have other plugins turned off, and that you are using the latest versions of WordPress and Gravity Forms.

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  29. Okay, I just tried this. It says Meta recovered successfully, however the form is still not found and there are still no fields when I go to edit the form.

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  30. David Peralty
    Administrator

    Okay, at this point, one of our developers will have to take a look. Can you send me both WordPress Admin login details and FTP access details to peralty@rocketgenius.com with a link to this forum thread please?

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  31. Okay, I will get this information to you ASAP, thank you for your assistance.

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  32. Same here - will email

    Posted 6 years ago on Wednesday May 8, 2013 | Permalink
  33. Anonymous
    Unregistered

    I'm seeing the original issue posted here as well, on Multisite with WP Super Cache enabled. See here: http://spudpickles.com/submit-a-ghost-story/ but if I login (thereby serving the non-cached version) or if I turn off WP Super Cache for that individual site, then it displays just fine. The same happens on other sites in the network, such as this one: http://imagesbeauty.com.au/ (scroll down a little ways on the home page--currently caching is disabled on this site, so you should see the form just fine).

    I contacted GF priority support, but he merely said to check with the WP Super Cache people. However, now that I've seen this thread, it seems the problem was introduced with the GF 1.7 update. These were working just fine before.

    The crazy part of all this is that other sites on the same Multisite load their forms just fine: http://coolkidschairs.com/contact/

    Posted 6 years ago on Monday May 13, 2013 | Permalink
  34. Anonymous
    Unregistered

    UPDATE: I think I've figured it out... or at least how to fix. It must be that a change in GF 1.7 is not compatible with something cached from previous versions. I went to /wp-content/cache/supercache and deleted the "spudpickles.com" folder, and did the same in /wp-content/cache/blogs. This forces a full re-fresh of the site's cache, because that's all the files for the cache. Once I did that and reloaded the pages in an incognito (Chrome) window, to ensure I was not logged-in, they loaded up fine. I also check the source and at the very bottom WP Super Cache puts some text to let you know if the page is cached or not. It was cached, so it had rebuilt the cache for that page, but now the form was showing up just fine.

    There was no cache folder(s) for the imagesbeauty.com.au site, so I just re-activated caching on it, and the form on the home page is working fine there as well. Not sure if this is the same problem everyone else on this thread is having, but it sounds similar. So for people like Wilco who originally started this thread, I'd say try deleting everything inside the wp-content/cache/supercache and /blogs folders. See if that fixes it. It did for me!

    Posted 6 years ago on Monday May 13, 2013 | Permalink
  35. I don't have caching on the site that I'm experiencing the issue so I think it's more than just a caching issue.

    Posted 6 years ago on Tuesday May 14, 2013 | Permalink
  36. Just a FYI - I tried it with 1.7.4 and get the same thing.

    Posted 6 years ago on Wednesday May 22, 2013 | Permalink
  37. David Peralty
    Administrator

    Scott, this thread has gotten so unwieldy. Can you create a new thread, explaining your issue and what you've tried so far, so we can better support your needs?

    Posted 6 years ago on Wednesday May 22, 2013 | Permalink
  38. Sure, although it's the exact problem as the thread was started as :-)

    Posted 6 years ago on Thursday May 23, 2013 | Permalink
  39. Yes, and we are still waiting for someone to send us a WP Admin login and FTP Access to troubleshoot, but no one has. Scott, I've asked that you do so in your new forum post you created.

    Posted 6 years ago on Thursday May 23, 2013 | Permalink

This topic has been resolved and has been closed to new replies.