PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Forms not showing, inline style="display:none"

  1. Forms not showing since latest update. I removed all other plugins and applied default theme.

    http://sitesubscribe.com/form-test/

    contains shortcode:
    [gravityform id="1" name="Get In Touch" description="false"]

    The HTML for the form (gf_browser_chrome gform_wrapper) now has an inserted inline style of style="display:none".

    I had to do a CSS override to get forms to show:
    .gform_wrapper {
    display: block !important;
    }

    Posted 8 years ago on Wednesday February 6, 2013 | Permalink
  2. Please remove that custom CSS so we can see what the conflict might be. I can see the form now (in Firefox) but that is likely due to the CSS you added.

    When a form does not display and is hidden by "display:none" it is normally due to a JavaScript error which prevents the Gravity Forms jQuery from running. To test for this, please follow these instructions to check for theme and plugin conflicts. http://rkt.gs/testing

    Posted 8 years ago on Thursday February 7, 2013 | Permalink
  3. I had already mentioned that I removed all other plugins and applied default theme.

    Posted 8 years ago on Thursday February 7, 2013 | Permalink
  4. Great. Thank you for checking that. Sorry I missed that the first time around. Have you removed the CSS which is currently forcing the form to show? If you can remove that, we can better check for a JavaScript error or jQuery conflict. Thank you.

    Posted 8 years ago on Thursday February 7, 2013 | Permalink
  5. Sorry, this is a production site and I haven't been able to remove the CSS since my forms will go away.

    Posted 8 years ago on Friday February 8, 2013 | Permalink
  6. I thought this page was a test page? "form test"? Can you duplicate this form and embed the duplicate in a page, and exclude that page from your menus?

    If you applied your CSS to all Gravity Forms (which is looks like you did with .gform_wrapper), please change it to target just the production forms by using #gform_wrapper_1, for example. We won't be able to troubleshoot much without being able to see the problem.

    One test you can perform: does the form display properly in the form preview, without your CSS override being applied?

    Posted 8 years ago on Saturday February 9, 2013 | Permalink
  7. I noticed this stylesheet is referenced in the head of the page, but it returns a 404 error.

    http://sitesubscribe.com/wp-content/themes/enterprise/style.css?ver=1.9.1

    Just FYI: it's not related to this problem.

    Posted 8 years ago on Saturday February 9, 2013 | Permalink
  8. Thanks for noticing that. I had renamed that file since I'm using an external style sheet exclusively.

    I noticed today on another site that the latest version of Gravity Forms has a conflict with Jetpack. The GF admin screen is unusable (can't rename the form, all field options are expanded so can't get to update button, etc.).

    Not a huge issue since I don't like Jetpack that much anyway so I just removed it.

    I don't think this is related to other problem since I had removed all other plugins.

    Posted 8 years ago on Saturday February 9, 2013 | Permalink
  9. True. We've heard of conflicts with JetPack recently . But that is not an issue on this installation since you've already disabled all the other plugins.

    Do you have a URL where the form is embedded where you did not apply your CSS fix? I'd like to see a page where the form does not display, but should.

    Posted 8 years ago on Saturday February 9, 2013 | Permalink
  10. I'm having this same problem: forms are showing an inline style of display:none. I disabled all the plugins except Gravity Forms, and still the inline style is generated of display:none. These forms were showing without any problem until at least mid-January.

    One of the forms is here:
    https://ohalah.org/annual-conference/2013-conference/registration/ancillary-payments/

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  11. A form that *does* work, and uses the same page template is here:
    https://ohalah.org/annual-conference/2013-conference/registration/members/

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  12. David Peralty

    Looks like it might be a conflict with the User Access Manager. Can you try disabling that plugin and seeing if your forms work?

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  13. User Access Manager is disabled and I still have the problem. But after disabling and reenabling all the plugins, I looked at this page http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Switching to the Twenty Ten theme causes the form to appear.
    The site is a child theme of Twenty Ten, so I figured the problem must be in functions.php, but after renaming that file to xfunctions.php, the form still doesn't reappear.

    Where else could the problem be?

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  14. David Peralty

    Usually this is a JavaScript issue, which is stopping conditional logic from working, thus causing the form not to show.

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  15. Okay, thanks. I'll look around some more.

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  16. It doesn't seem to be a JavaScript issue, because when I open the page with JS disabled, the form is still loaded with display:none as an inline style.

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  17. Richard Vav
    Administrator

    @callibeth your page is loading jQuery twice, in the header you are loading the correct version (1.8.3 local) but in the footer you are loading version 1.4.4 from google, you need to remove this second jQuery include and then see if your problems persist.

    When page containing a form using conditional logic loads it always starts off with display:none as an inline style, this is normal behaviour, the conditional logic will then reveal only the parts of the form that need to be displayed.

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  18. Thanks! I'll look into this.

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  19. David Peralty

    Javascript is how we make Conditional Logic work. We hide everything, and then just show the fields that are needed. Hence the display:none at the top of the form. Disabling JavaScript wouldn't fix a JavaScript issue. Thanks richard for catching that two JQuery problem.

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  20. That did it. Thanks!

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  21. David Peralty

    Glad you got it sorted out. Hopefully this thread helps others. All my best!

    Posted 8 years ago on Friday March 22, 2013 | Permalink
  22. Just for others' benefit perhaps, I had a similar issue with a form that had some conditional logic which had been duplicated from another form. Not sure if this was a factor, but simply removing all the conditional logic, then re-applying it solved the issue.

    Posted 8 years ago on Tuesday March 26, 2013 | Permalink
  23. David Peralty

    Thanks for posting. Sometimes, if you change a field that is tied into Conditional Logic, you can break conditional logic, and a quick reset like that can fix it all. Glad you were able to figure it out. All my best!

    Posted 8 years ago on Tuesday March 26, 2013 | Permalink