PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Forms not working after switching directories

  1. tdale
    Member

    Contact form used to be at in my development folder at http://trulendingmortgage.com/bwd/contact/ and worked fine. I moved the website to the root so the contact form is now at http://trulendingmortgage.com/contact/. I did this by moving the index.php and .htaccess files to the root and changing the path in the index.php and within the wordpress admin. Rest of site shows up fine. But now, when you fill out form and click submit, the form just resets. No data is captured, no notification emails are received. If I try to preview the forms from within admin, then "Page not found". I tried to duplicate the form and resave and I get some kind of ajax error. Same issue with my one other form under the "Loan Center" link.

    Posted 9 years ago on Tuesday September 13, 2011 | Permalink
  2. Sounds like your form meta (the serialized values) got messed up when you moved the site. Try the Meta Recovery Tool on the downloads page:

    http://www.gravityhelp.com/downloads/

    Posted 9 years ago on Tuesday September 13, 2011 | Permalink
  3. tdale
    Member

    Hi Chris,
    I had previously tried the Meta Recovery Tool based on other post unsuccessfully. This morning I deactivated and deleted the Gravity Form plugin and then re-installed hoping that would help. I also tried creating the form from scratch and then using the Meta Recovery Tool again. In both cases, the same problems persist. The form is visible, but when entering info and clicking submit, it resets to blank and no info captured anywhere. If I try to preview the form from within the plugin, I get "Page Not Found".
    - Thomas

    Posted 9 years ago on Tuesday September 13, 2011 | Permalink
  4. The form action isn't being triggered so the form isn't submitting. This is going to be a URL rewriting issue most likely related to bad configuration in your .htaccess file.

    One thing to try is delete your .htaccess file, then use WordPress to regenerate it by going to Permalinks and saving permalinks settings.

    Posted 9 years ago on Tuesday September 13, 2011 | Permalink
  5. tdale
    Member

    Thanks Carl. The issue appears to be related to my GoDaddy hosting (still not exactly sure how as of yet) Using windows/shared hosting IIS Version 7.0, PHP Version 5.2. They don't use . htaccess, but instead want me to update a web.config file which i'm done every which way from Sunday now with no success. I've been able to find lots of complaining about similar issues, but no solutions so far :( Very frustrating.

    Posted 9 years ago on Tuesday September 13, 2011 | Permalink