PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Forms submit but they don't confirm and seem to load indefinitely

  1. All of my forms, both in preview and in their places on the site, will submit (they don't send notifications, which I'm not sure is a related problem or not, but at this point, nothing would surprise me), but the user doesn't get any kind of confirmation that it's been submitted because the page just keeps loading. The user does receive an error message if a field is filled out incorrectly, though, so it seems only to be a submission error.

    I've tested this with Ajax activated and deactivated and the results are consistent.

    http://www.resamichellemedia.com/contact
    http://www.resamichellemedia.com/project-proposal-request

    Posted 6 years ago on Friday November 16, 2012 | Permalink
  2. Jive Software
    Member

    Do you have conflicting plug in?
    I noticed this promted a resource failed to load error in my inspector:
    http://www.resamichellemedia.com/wp-content/plugins/flexi-quote-rotator/styles/

    Or is it something with your hosting provider?

    Posted 6 years ago on Friday November 16, 2012 | Permalink
  3. I'm having a serious issue with Notifications too. They simply aren't working. However, confirmations seem to work. Any guidance would be great.

    Posted 6 years ago on Friday November 16, 2012 | Permalink
  4. ResaMichelle - please begin by testing for theme and plugin conflicts by following these instructions http://rkt.gs/testing

    That will help solve the problem of 'no confirmation' being shown to the user.

    The notifications is a separate issue altogether and we'll handle it as such.

    Posted 6 years ago on Saturday November 17, 2012 | Permalink
  5. @sethneal, your issue is the opposite of ResaMichelle's. Please begin a new topic for your issue and include a link to your website and the page with the form where this can be observed.

    For notification delivery issues, assuming the configuration is correct, we normally first recommend installing an SMTP plugin to get around any restrictions your host may have with the built in mail function.

    (you can try any of these, but just one is required):
    http://wordpress.org/extend/plugins/cimy-swift-smtp/
    http://wordpress.org/extend/plugins/configure-smtp/
    http://wordpress.org/extend/plugins/wp-mail-smtp/

    Posted 6 years ago on Saturday November 17, 2012 | Permalink
  6. @chris, thanks so much. I have no idea why I started at the bottom of your list, but Cimy Swift SMTP was the only one that actually worked for me!!! BUT, its working! Thanks a ton.

    Posted 6 years ago on Saturday November 17, 2012 | Permalink
  7. There's no conflict with the theme, the plugins all clear, I added Google Libraries to no avail. However, I'm now receiving messages, so that's a plus.

    Posted 6 years ago on Saturday November 17, 2012 | Permalink
  8. @ResaMichelle, can you submit the form successfully from the form preview?

    Posted 6 years ago on Saturday November 17, 2012 | Permalink
  9. @Chris Hajer The previews have the same problem. They submit successfully on the back end, but seem to load indefinitely on the user end.

    Posted 6 years ago on Sunday November 18, 2012 | Permalink
  10. I'm sorry, I see now that you mentioned that in your initial topic. Can you please send me a WordPress administrator login to chris@rocketgenius.com so I can take a look at this. Thank you.

    Posted 6 years ago on Sunday November 18, 2012 | Permalink
  11. I replied to your email. I am getting a 500 Internal Server error if I wait until the request eventually times out after form submission. Please check your host's error logs for what that error might be.

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  12. I checked with my hosting company, and the error they receive on their side reads:
    Script timed out before returning headers: index.php, referer:
    http://www.resamichellemedia.com/contact

    There are no related errors in the error log in the public_html file.

    Posted 6 years ago on Friday November 23, 2012 | Permalink