PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

GF unable to submit website field or any html

  1. I don't know if I'm missing something really obvious here but I cannot get any form to allow the submission of html code in the body field or the website field.

    I have created a test form with just title, website and body and this doesn't submit either. It just redirects back to the form with no error given. However, on removal of the http:// from the field and submitting with this field as empty - it submits!

    I have cleared all plugins and tried it on the basic theme to no avail. I have an adaptation in my functions.php file that allows me to include mapping in my forms, but even deleting that had no effect...

    This was on my live site and this has been duplicated on my test site - so I'm not sure if there's something in the server settings that could be causing this. Some sort of file permission or something that prevents html from being posted? Though I doubt that it's a setting in wordpress itself as I'm posting as admin.

    The only error I can find with console is:
    Resource interpreted as Other but transferred with MIME type undefined.

    The simple form is here: http://www.madfall.com/test-post-submission
    while the new form I'm looking at is here: http://www.madfall.com/uploads

    About the only thing I haven't done is created a NEW site and see if i can recreate the error that way - but hoped someone might be able to enlighten me before i had to go to those lengths (and while I've read somewhere that I'm ok to use my licence on my development/test site, I don't want to start another site unless that's against my licence?).

    Thanks.

    Posted 10 years ago on Wednesday December 21, 2011 | Permalink
  2. I recall this happening once before. I don't know that the resolution was ever posted:
    http://www.gravityhelp.com/forums/topic/advanced-field-website-question

    If I remove the http, it goes through and I get a confirmation message. If I leave the http in there, it just refreshes with no errors.

    I wonder what would happen if you removed the comment form from the page?

    Posted 10 years ago on Wednesday December 21, 2011 | Permalink
  3. Thanks Chris - I've removed the comment field and still nothing... Tried what I could see on the link you posted (reasving the permalinks) and again - nothing.

    I think I'll have to try and replicate this on another domain on the same hosting for testing - just to see if I can recreate this problem a third time - but this time with no plugins at all and just the usual theme - you never know what some of the plugins might have changed along the way.

    BTW - this has been happening since I bought it a few months ago, so can also rule out the recent upgrade to WP3.3.

    Will update the thread once I've done the above....

    Posted 10 years ago on Wednesday December 21, 2011 | Permalink
  4. This could very well be some sort of server or firewall setting.

    I'm not able to reproduce any issues with being able to submit form data that contains HTML in fields that allow it. There is nothing in Gravity Forms itself that will strip out the HTML if it's a field that does indeed support HTML such as the Website field.

    Do you have any sites on any other servers that you can test with? Who is your web host?

    Posted 10 years ago on Wednesday December 21, 2011 | Permalink
  5. I'm currently hosting with 4u Hosting in the UK - I'll try and reproduce it on a totally clean site with them and if it causes the same problem I'll go after them to see if they've got a setting that's stripping the html out.

    My operational site is on http://www.mudandroutes.com - there's a few forms on there that work perfectly except I cannot submit html. I found that out as I created a load of html (links and formatting in excel) that I wanted to submit via the forms and it just blocked the submission with no error and returned to the form (but a blank form).

    Posted 10 years ago on Wednesday December 21, 2011 | Permalink
  6. @walkeryri Another thing to note, what are the exact field types you are using that you are trying to enter HTML into? Not all fields accept HTML. Most don't for security reasons to prevent malicious code from being submitted.

    The website field accepts an http:// URL which isn't technically HTML and the Post Body field should accept HTML. The basic Paragraph Text field, however does not process HTML... although it can be enabled via a hook.

    Posted 10 years ago on Wednesday December 21, 2011 | Permalink