PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Gravity forms admin should have SSL support

  1. howdy
    Member

    When accessing:
    https://domain.com/wp-admin/admin.php?page=gf_entries

    The Edit columns button is:
    http://domain.com/?gf_page=select_columns&id=3&TB_iframe=true&height=365&width=600
    (it should be https://... )

    Which breaks the SSL (padlock broken) and doesn't allow and changes to be saved in the field columns.

    We administer many sites with SSL support in the backend, this bug is affecting every one of them.

    Fix: address url's with this method to instantly work on http and https http://paulirish.com/2010/the-protocol-relative-url/

    Posted 7 years ago on Tuesday October 2, 2012 | Permalink
  2. I've flagged this one for feedback from the developers. Thank you.

    Posted 7 years ago on Wednesday October 3, 2012 | Permalink
  3. Gravity Forms uses the built-in WP function site_url() to create all internal URLs. That WP function tries to use the appropriate scheme, but it is known to have problems with Proxy servers and not "realize" that the URL is using the https scheme, because those Proxy servers set different server variables. What you can do is use the "site_url" filter and return the URL with the https scheme instead.

    I will be looking at better ways of getting these URLs so that we don't have this problem.

    Posted 7 years ago on Wednesday October 3, 2012 | Permalink
  4. howdy
    Member

    Hi Alex,

    Actually site_url() does fetch the HTTP/S specific version of the url.

    Very strange but if you add:
    <?php echo site_url(); ?>
    just above
    < a >" href....
    in entry_list.php

    it loads the correct url. Seems like something to do with how it's being used in the href part of the script?

    Posted 7 years ago on Thursday October 4, 2012 | Permalink
  5. howdy
    Member

    Further to this, it even outputs correct but then shows up as http?

    <?php $select_site_url = site_url()."?gf_page=select_columns&id=$form_id&TB_iframe=true&height=365&width=600";
    echo $select_site_url;
    ?>
     <a title="<?php _e("Select Columns" , "gravityforms") ?>" href="<?=$select_site_url?>" class="thickbox entries_edit_icon"><?php _e("Edit", "gravityforms") ?></a>
    Posted 7 years ago on Thursday October 4, 2012 | Permalink
  6. howdy
    Member

    Ok, definitely a gravity issue and not a site_url() problem.

    Hardcoding the domain in https loads as http:

    <a title="<?php _e("Select Columns" , "gravityforms") ?>" href="https://domain.com/?gf_page=select_columns&id=<?php echo $form_id ?>&TB_iframe=true&height=365&width=600" class="thickbox entries_edit_icon"><?php _e("Edit", "gravityforms") ?></a>

    outputs in html as:

    <a title="Select Columns" href="http://domain.com/?gf_page=select_columns&id=1&TB_iframe=true&height=365&width=600" class="thickbox entries_edit_icon">Edit</a>
    Posted 7 years ago on Thursday October 4, 2012 | Permalink
  7. Gravity Forms doesn't do any special HTML processing to replace that https with http, so I am not sure what is doing that replacement. If you type that URL directly in your browser, does it get replaced with http?
    My guess is that there is something either in your web server or other WP plugin doing a redirect from https to http.

    Posted 7 years ago on Monday October 8, 2012 | Permalink
  8. howdy
    Member

    Alex, can you test to see if you can reproduce this on an SSL version of WP? I can assure you it is doing this on all our websites.

    This error is produced in the actual source code of the website:
    view-source:https://domain.com/wp-admin/admin.php?page=gf_entries

    Posted 7 years ago on Friday October 12, 2012 | Permalink
  9. I can't reproduce it. It works OK for me here. All the links have https:// when I load the admin under https://
    Take a look a the following screenshot:
    http://grab.by/gM3o

    Following is the source code from it:
    http://pastie.org/pastes

    Have you tried going through the Plugin and Themes conflict (http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict) to see if this is being caused by another plugin or your theme? I can assure you this is either a conflict with exterior code (plugin or theme), or a setting in your web server / proxy. I would try the plugin/theme conflict first.
    Can you setup a test site that reproduces the problem so that we can play around with it?

    Posted 7 years ago on Monday October 15, 2012 | Permalink