PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Gravity Forms and File Uploads

  1. admin@clickcom.com
    Member

    I am using gravity forms for an employment application at http://www.lutheranhomessc.org/employment-application

    If a user submits any file uploads, the form never gets to the final step.
    I have removed all customizations to gravity forms that I had in my functions.php (like adding an attachment to the admin notification) to remove that being the problem.

    if testing, please be SURE to choose "Jonathan at Heritage" (this is sent to a admin email).

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  2. You have a tabindex problem going on on that page because you have two forms there. Tabbing from field to field in the main form takes you temporarily to the sidebar form. Take a look at this documentation for ways to change the tabindex for your forms so there is no conflict, and the user is not confused.

    You can set it in the shortcode:
    http://www.gravityhelp.com/documentation/page/Shortcodes#Form_Shortcode

    You can set it in the widget settings (if you are using the form in a widget)

    Or you can use a function to change the tabindex on one form or all forms:
    http://www.gravityhelp.com/documentation/page/Gform_tabindex

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  3. I made it through the form and uploaded 1 PDF, for the first file upload field, I forget what it was. I was able to complete the form and saw this confirmation at the end:

    Thank you for your interest in employment with Lutheran Homes of South Carolina! We may be in touch with you regarding your application.

    Can you explain exactly what type of file I can upload, and in which field, which will prevent successful completion of the form? It's a long form and will be difficult for us to recreate all possible scenarios where this could be a problem. Does it only happen when it's a certain type of file, or size of file, or if multiple files are uploaded?

    Please describe a test case for us so we can try and recreate the problem on our end. Thank you.

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  4. admin@clickcom.com
    Member

    I just uploaded a docx to all available file uploads. I will try out the things you posted.

    Posted 6 years ago on Tuesday November 20, 2012 | Permalink
  5. admin@clickcom.com
    Member

    Okay, so after setting the tab index to something different, I realized that you were just recommending that from a ux perspective.
    On the original question - as I said, I just uploaded a docx (very small, just one line of text in it) to every available upload box. The problem occurs right after the question 'have you ever served in the military'. There are two file upload inputs directly above this question. After clicking next on this page, the form just quits - the next page has all the regular content but no form. The 'entry-content' div is blank except for the page edit link.

    Posted 6 years ago on Tuesday November 20, 2012 | Permalink
  6. I tried just what you described just now and I have the same error. The only thing I can see is that jQuery is being loaded twice, once very early on, right after the page < title > and once later, as expected, by Gravity Forms. Can you remove the first call to jQuery? This one:

    [html]
    <script src="http://www.lutheranhomessc.org/wp-includes/js/jquery/jquery.js"></script>

    If you remove that early jQuery, the following script will stop working, because jQuery is not available before you add this to the page. You'll need to change the order of the scripts to ensure this one is loaded after jQuery is available.

    [js]
    <script>
    jQuery(function(){
    jQuery('#input_3_2').attr('placeholder','(last, first, middle initial)');
    });
    </script>
    Posted 6 years ago on Wednesday November 21, 2012 | Permalink
  7. admin@clickcom.com
    Member

    I removed that first call (and the entire placeholder script). The form still exhibits the same problem. Thanks for your help thus far.

    Posted 6 years ago on Wednesday November 21, 2012 | Permalink
  8. admin@clickcom.com
    Member

    Any updates on this? It's been four days.

    Posted 6 years ago on Monday November 26, 2012 | Permalink
  9. You caught us on the holiday and then the weekend. Sorry for the delay. Because you are a developer license holder, you can always take advantage of the priority support as well. http://www.gravityhelp.com/priority-support/

    Looking at your form again, I see some invalid HTML in field 168 (you have "<tr style="page-break-before: always">" without being enclosed in a table). Can you fix that please? That can cause problems with form submissions sometimes and might be causing some trouble with the uploads. I'm not sure if that's causing your trouble or not, but we're knocking down one issue at a time.

    Posted 6 years ago on Tuesday November 27, 2012 | Permalink
  10. admin@clickcom.com
    Member

    Thanks for your help Chris - I removed the HTML there and nothing changed. I have submitted a priority support ticket. I had forgotten that was an option available to me.
    Thanks again.

    Posted 6 years ago on Tuesday November 27, 2012 | Permalink
  11. Please update the topic here once you have a resolution. Your situation is a strange one, for sure, and I would like to hear how it gets resolved.

    Posted 6 years ago on Tuesday November 27, 2012 | Permalink
  12. admin@clickcom.com
    Member

    Chris,

    Just an update - I have been emailing Rob back and forth:

    1. With all plugins disabled, the form works (theme made no difference).

    2. I setup a local copy of the site (as it is a live site and I can't be disabling plugins/themes) with xampp. On the fresh copy of the site and db from the live site to my local site, the form works - with all plugins ACTIVE!

    3. I checked file permissions for the uploads folder and the gravity forms folder inside the uploads folder on the live site.The permissions are fine (755 on folder, 644 on files). I can also see files that uploaded fine from the pages BEFORE the page (the military page) that causes this problem.

    Just wanted to post the latest here in case you or a community member may have some wisdom to share on the matter.

    Also - apologies on my impatient comment above. This site has been a challenge from the get-go and this problem has been driving me crazy! Thanks for your help.

    Posted 6 years ago on Friday November 30, 2012 | Permalink
  13. Can you set up a test site on the same server, rather than localhost, to see if the problem still exists there? Mabye it's something about the server. The form worked with all plugin disabled, on this server, and it worked on XAMPP/localhost, with all plugins ACTIVE. Maybe there is something about one of the plugins on your server which is causing the problem. Since you can't take the live site down, how about creating an identical site on the same server and seeing if you can find the actual plugin which is in conflict.

    Posted 6 years ago on Saturday December 1, 2012 | Permalink