PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Gravity Forms Pricing Fields - Option - Drop Down Required

  1. ehong33234
    Member

    Using WooCommerce and GF Product Add-ons on latest GF.

    For the Pricing Fields OPTION Drop Down, when I toggle on Enable Enhanced User Interface, the added cost variables (i.e. +$25.00) does not show on the front end. If I turn off the Enable Enhanced User Interface option, the added cost displays properly. I believe this is a bug.

    Posted 5 years ago on Wednesday November 7, 2012 | Permalink
  2. ehong33234
    Member

    I tested this some more and noticed that the cost display properly even under Enable Enhanced User Interface (EEUI) if the field is a conditional field. When the field is not conditional, the EEUI dropdown will not display the +price next to the added option.

    Posted 5 years ago on Wednesday November 7, 2012 | Permalink
  3. Please post a link to the form where this is visible. Thank you.

    Posted 5 years ago on Wednesday November 7, 2012 | Permalink
  4. ehong33234
    Member

    You can find the product here: http://goo.gl/4lMRm

    The first drop down should have +pricing on it, which it does not. However, if you click "yes" below that it will activate conditional fields, in which case the drop down does show the +price.

    Thanks!

    Posted 5 years ago on Wednesday November 7, 2012 | Permalink
  5. I'm seeing the same issue. When using an Enhanced User Interface drop-down for my option pricing fields, the +pricing is only shown if display of the the drop-down field is conditional.

    My URL is https://www.ihomefinder.com/product/optima-express/test-account-info-form/, with the very last field being the one in question. It is conditioned on the very first field not being set to "--Select--". (Note, this page is under development and may change by the time anyone looks at it.)

    Posted 5 years ago on Friday November 9, 2012 | Permalink
  6. ehong33234
    Member

    Hi Glenn, thanks for chiming in. Glad to see that I'm not the only one seeing this. How about it GF guys? =)

    Posted 5 years ago on Friday November 9, 2012 | Permalink
  7. Can someone please export their form as XML (Import/Export menu, then the top center menu item, "Export Forms") and email it to me at chris@rocketgenius.com . I'd like to try the form without the woocommerce add-on to see if the problem still exists.

    Thank you.

    Posted 5 years ago on Saturday November 10, 2012 | Permalink
  8. I sent the form XML to GF but haven't back from them (albeit I sent it 4 months after their request). However, I found placing the following JavaScript in the footer of my page with the form resolves the issue.

    [js]
    <script>
    jQuery(document).ready(function() {
      gformInitPriceFields();
    });
    </script>
    Posted 5 years ago on Wednesday March 20, 2013 | Permalink
  9. Thanks Glenn. I did find your email in my spam folder. Sorry, I was not expecting your form. Thank you for posting an update.

    Posted 5 years ago on Saturday March 23, 2013 | Permalink

This topic has been resolved and has been closed to new replies.