PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

"Gravity Forms require WordPress 3.0 or greater." error

  1. hpagnacco
    Member

    Hi there. I just renewed my Developer License, and upgraded the plugin through Wordpress, and now I am seeing this error: "Gravity Forms require WordPress 3.0 or greater. You must upgrade WordPress in order to use Gravity Forms"

    The website is using Wordpress version 3.0.3. Why am I seeing this error?

    Upgrading Wordpress to use GravityForms could cause the Theme and other plugins to return errors/fail.

    Your help is appreciated!

    Posted 10 years ago on Monday May 14, 2012 | Permalink
  2. As noted on the footer of the site, Gravity Forms requires a minimum of WordPress version 3.3+, MySQL 5, PHP 5 and JavaScript enabled in order to function properly.

    Posted 10 years ago on Monday May 14, 2012 | Permalink
  3. hpagnacco
    Member

    Thank you for the clarification. I recommend updating the error message. Thanks again,

    Holly

    Posted 10 years ago on Monday May 14, 2012 | Permalink
  4. Technically it requires WordPress v3.2, although we have updated the sites to say WordPress v3.3.

    You are receiving this message as it is a mistake in the code related to the display of this message. Gravity Forms currently requires v3.2 at a minimum due to jQuery requirements and changes made in WordPress as it relates to jQuery usage. WordPress made major changes to it's built in jQuery in WordPress v3.2 and Gravity Forms uses the jQuery built into WordPress.

    So that message SHOULD say "Gravity forms requires WordPress v3.2 or greater." You are receiving it because you are using WordPRess v3.0.3.

    Is there any reason why this site has NOT updated to WordPress v3.3+? Running old versions of WordPress is not advised. You should always update WordPress and plugins whenever updates are available. These software solutions are not install once and never update types of solutions. Running old versions of WordPress leaves your site vulnerable to being hacked or being infected with malware. Updates are extremely important from a security standpoint.

    Not updating WordPress and running old versions is a bit like leaving your windows and doors open at all times, even when you are not home.

    Posted 10 years ago on Monday May 14, 2012 | Permalink