Technically it requires WordPress v3.2, although we have updated the sites to say WordPress v3.3.
You are receiving this message as it is a mistake in the code related to the display of this message. Gravity Forms currently requires v3.2 at a minimum due to jQuery requirements and changes made in WordPress as it relates to jQuery usage. WordPress made major changes to it's built in jQuery in WordPress v3.2 and Gravity Forms uses the jQuery built into WordPress.
So that message SHOULD say "Gravity forms requires WordPress v3.2 or greater." You are receiving it because you are using WordPRess v3.0.3.
Is there any reason why this site has NOT updated to WordPress v3.3+? Running old versions of WordPress is not advised. You should always update WordPress and plugins whenever updates are available. These software solutions are not install once and never update types of solutions. Running old versions of WordPress leaves your site vulnerable to being hacked or being infected with malware. Updates are extremely important from a security standpoint.
Not updating WordPress and running old versions is a bit like leaving your windows and doors open at all times, even when you are not home.
Posted 10 years ago on Monday May 14, 2012 | Permalink