PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Gravity Forms User Roles Access

  1. Chris
    Member

    I've had some code in my themes functions.php to allow authors to export gravity forms and it's worked in the past. For some reason, it now isn't working.

    The code I have is

    //Gravity Forms User Roles Access
    $edit_contributor = get_role('author');
    $edit_contributor->add_cap('gravityforms_export_entries');
    //END Gravity Forms User Roles Access

    The strange thing is that they appear to have access but when they click the export link in the forms menu, the url they get is

    http://domain.com/wp-admin/gf_export

    instead of

    http://domain.com/wp-admin/admin.php?page=gf_export

    Which is why it is obviously broken for them. It is working for me (as an admin) Any ideas?

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  2. David Peralty
    Administrator

    Are you using any other role management plugins/code? Can you change your permalinks, save them, and then change them back and test? I'm also going to reach out to our developers to see if they know of anything off the top of their heads.

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  3. Chris
    Member

    No other role management plugins. I'll check on the permalinks

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  4. David Peralty
    Administrator

    Can you also have them try the correct link and see what happens?

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  5. Chris
    Member

    Changing the permalinks may have helped. Let me consult with the users that are set as authors that were having this issue. Thanks

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  6. Chris
    Member

    To answer your question, if I send them the correct link it works just fine.

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  7. Chris
    Member

    It appears the issue has been fixed by resetting the permalinks. Thanks for that recommendation.

    I didn't really think the permalinks would affect the admin functions!

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  8. David Peralty
    Administrator

    Permalinks can affect everything... Especially if you have caching enabled. All my best.

    Posted 6 years ago on Thursday July 11, 2013 | Permalink

This topic has been resolved and has been closed to new replies.