PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Gravity Forms with Cart66 not processing Image Uploads

  1. We're having almost all Customers fail to purchase through the site http://www.swiftprintuk.com.

    It seems we have two on going issues possibly linked.

    Customers are selecting products and the product is failing to add to the cart at all.
    Example of this is: Canvas product, select to upload a photo later, enter email and the product fails to add to the cart.

    The second issue is that our Uploader is failing to upload the artwork. The form processes but the the image doesn't attach/reach as far as us. The message on the processed form email for the upload reads:

    FAILED (Temporary file could not be copied.)

    The problem seems to be intermittent. We've got the latest version of Cart66, Gravity Forms and WordPress installed.
    Out Hosts have also reported that they have not updated any server site settings.

    Unsure where the issue is and we're currently loosing business due to this.

    Please can anyone help?

    Posted 7 years ago on Tuesday December 11, 2012 | Permalink
  2. This error "FAILED (Temporary file could not be copied.)" could be for several reasons, all of which are due to server configuration. There would be a maximum time limit for execution of the script, and that could be timing out. The image may be too large to be handled by the server. The permissions could be wrong on the wp-content/uploads/gravity_forms folder, although that would probably affect all uploads.

    I would look at your php.ini settings (or php info) to see what restriction may be in place that would cause a problem with an image upload.

    Can you try testing with images of different file sizes, going larger and larger until you receive an error?

    Regarding adding to the cart, I'm not familiar with Cart66 integration, but it seems that it would be something in the configuration.

    Let's try resolving the image upload problem first and see if that helps with the cart issue.

    Posted 7 years ago on Thursday December 13, 2012 | Permalink