PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Gravity problem in Wordpress 3.0.5?

  1. guildmeister
    Member

    I've just installed a new wordpress site, it's using version 3.0.5. When I try to activate Gravity Forms I just get a totally white screen. So there's a problem somewhere, but it's not failing and being caught and deactivated by Wordpress, no error messages are visible. When I remove the plugin files through FTP, Wordpress works fine.

    I have tried installing by uploading the un-zipped plugin folder through FTP. This is the same version of the plugin that is working fine on Wordpress 3.0.4 sites. I've also just downloaded a fresh stable version of Gravity 1.4.5 and uploaded it directly through the plugins area to make sure nothing got corrupted in the FTPing process. Same thing happens.

    I do have other plugins installed, but they are the same plugins that are working fine with Gravity under WP 3.0.4. I'm not sure that it's a 3.0.5 problem, but I know for sure it works under 3.0.4. The only other thing that might be different on this site is it's also using the latest version of Akismet 2.5.3

    Any ideas what's going on and how I can fix it?

    Posted 10 years ago on Wednesday February 9, 2011 | Permalink
  2. pats@etoolsmiths.com
    Member

    Hi,
    I also am having a problem with Gravity forms and WordPress 3.0.5.
    I tried the upload plugin install process to load the zip, it failed with a bad header error.

    I then unzipped and uploaded manually, but the plugin is not visible in the plugins area.

    I was able to install the mailchimp add on ok.

    I am using he thesis theme.
    thanks
    pat

    Posted 10 years ago on Wednesday February 9, 2011 | Permalink
  3. pats@etoolsmiths.com
    Member

    Hi,
    Update to the last message.
    i just tried 1.5rc4 and it installed fine.
    Forms look to be working ok.
    I guess the issue is in the production release.
    thanks
    pat

    Posted 10 years ago on Wednesday February 9, 2011 | Permalink
  4. @guildmaster This could be a PHP memory issue. When you run out of memory one of the things WordPress will do is give you the white screen of death. What is probably happening is WordPress 3.0.5 is probably using more memory so when you activate Gravity Forms you reach your limit and exceed your available PHP memory resulting in the white screen.

    Here are some articles on WordPress and how to increase PHP Memory:

    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    http://wordpress.org/support/topic/differences-in-methods-to-increase-php-and-wordpress-memory

    http://hecode.com/how-to-increase-php-wordpress-memory-limit/

    Posted 10 years ago on Wednesday February 9, 2011 | Permalink
  5. Elise
    Member

    I just got the wordpress white screen of death this morning after I tried to upgrade gravity forms to version 1.5 (as prompted in wordpress). The install failed and I got the white screen of death .... I'm hoping the articles you posted with fix it, fingers crossed!

    Posted 10 years ago on Wednesday February 9, 2011 | Permalink
  6. @pclFinance Typically the white screen of death is memory related. I am curious, however. We haven't released 1.5 via automatic upgrade. It's only available via manual upgrade as it's a development release. I'm guessing what you are referring to is upgrading to 1.4.5 and not 1.5. Either way, the white screen is typically memory related.

    Posted 10 years ago on Wednesday February 9, 2011 | Permalink
  7. Elise
    Member

    Hi Carl,

    I initially used the manual upload (as per the email from your support team) but it failed. Then I noticed in my dashboard the prompt to upgrade to version 1.5 which I thought was strange as I'd just received an email from support saying it wasn't publicly available yet but I tried it anyway and it failed - then I got the white screen of death ....

    I renamed the plugin folder and it didn't fix the issue but then I renamed the theme folder (crystal for genesis) and it fixed the problem. Weird - I hadn't touched anything today except try to upload the new gravity plugin.

    Do you think this is still likely a memory issue or should I head over to the studiopress support?

    Thanks,
    Elise

    Posted 10 years ago on Wednesday February 9, 2011 | Permalink
  8. Gravity Forms shouldn't conflict with Crystal or Genesis. It's probably a PHP memory issue.

    Posted 10 years ago on Wednesday February 9, 2011 | Permalink
  9. Elise
    Member

    Yeah we'll they were working fine together yesterday so that does make sense ... I'll investigate the memory issue first then :)

    Posted 10 years ago on Thursday February 10, 2011 | Permalink
  10. Elise
    Member

    Ok, so I installed a plugin (recommended from one of your links above) to see the php usage and it's only 2% (with the theme turned off). I'm working on this locally only, not sure if that makes a difference.

    Should I now go to Studiopress?

    Thanks again,
    Elise

    Posted 10 years ago on Thursday February 10, 2011 | Permalink
  11. It's difficult to debug the issue if you have it installed locally. It could be a problem with your local development environment. I would suggest trying it on a web server that we would be able to access and if the issue still occurs you could then give us access to the site to debug the issue.

    Posted 10 years ago on Thursday February 10, 2011 | Permalink
  12. Elise
    Member

    Looks like I read the upgrade as gravity when it was actually a genesis upgrade ..... so this issue is genesis. Sorry guys.

    Posted 10 years ago on Thursday February 10, 2011 | Permalink
  13. I am having the same "white admin screen of death" issue.

    I'm running WP 3.0.5 and started having issues when I bumped GF up to version 1.4.5.

    I tried manually upgrading to GF 1.5 and still get the white screen. Disabling GF by temporarily renaming the gravityforms directory name instantly brings back my WP admin.

    Also, I have used the "define('WP_MEMORY_LIMIT', '128M');" command in wp-config,php to bump the WP memory, and it has no effect on the white screen issue.

    Any other help or insight would be appreciated!!

    [EDIT]
    I am using GF with a custom theme (not Thesis or anything like that) for a client (a church): http://welcomebaptistchurch.org/prayer-requests/

    Posted 10 years ago on Thursday February 10, 2011 | Permalink
  14. Depending on your web host, simply changing the wp_memory_limit to 128M may not actually set your available PHP memory. You may need to check with your web host to see how to increase your available PHP memory. Sometimes you have to edit your PHP.ini file. It depends on your web host/server settings.

    Posted 10 years ago on Thursday February 10, 2011 | Permalink
  15. Thanks for the note back, Carl. I quick glance at the http://welcomebaptistchurch.org/phpinfo.php file shows the value as "memory_limit 128M"

    Would changing anything in the php.ini file help in this case?

    Posted 10 years ago on Thursday February 10, 2011 | Permalink
  16. Try deactivating ALL other plugins and activate the default WordPress theme and then activate Gravity Forms. It does work fine with 3.0.5 and the white screen issue is typically a memory related issue. So see what it does with only Gravity Forms, WordPress and Twenty Ten active and see if it works. It could be your site requires more than 128 MB of PHP memory, which is also entirely possible. But most sites do not and we've only had a handful of users report this issue when upgrading to WP 3.0.5 and it's always been memory related.

    Posted 10 years ago on Thursday February 10, 2011 | Permalink
  17. guildmeister
    Member

    Thanks for your reply Carl, those articles helped. I have bumped up the memory in both Wordpress and PHP to the max my host allows. I installed a plugin and out Wordpress was using more than the default the host had set, which was only 32MB.

    According to Wordpress the Multisite installations need 64MB, even though our hosting tech support guy was adamant that they didn't need more than 40MB. The site was using between 43 and 45MB even with no traffic and only 4 blogs. So I'm a bit worried about what the memory usage is going to go to when we go live and start getting traffic and more blogs added. Their maximum is only 64MB, which seems really limited to me given their other specs on the hosting plan we've chosen.

    Do you have any idea how much more memory Gravity is going to need when people are filling out the forms? They are allowed to upload 2 images, which is probably the most memory intensive task.

    Posted 10 years ago on Tuesday February 15, 2011 | Permalink
  18. 64 MB is fairly limited. Multi-Site does have more demanding memory requirements than standard WordPress. Some shared web hosts will have problems running Multi-Site installs because of the requirements.

    We were running our own sites on BlueHost without any problems with 64MB allocated. But it varies by host and Multi-Site is going to be more demanding. BUT 64MB may be sufficient.

    You may want to consider looking into hosts that have more flexibility in the amount of PHP memory that can be allocated.

    Posted 10 years ago on Tuesday February 15, 2011 | Permalink