PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

How can I put the valuta sign before the amount?

  1. In the 'Pricing Fields' the standard is that the valuta sign appears after the amount, but I want it before the amount.
    Is this possible?

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  2. Richard Vav
    Administrator

    You can use the gform_currencies filter in your theme's functions.php file to modify the position of the currency symbol.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  3. Thanks! I just changed it in the currency.php.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  4. Richard Vav
    Administrator

    We advise against editing the plugin files as any changes you make will be lost during updates, that is why I suggested adding the gform_currencies filter to your themes functions file.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  5. I added it in my functions.php but my amount changed from 35,00 euros to 3.500,00 euros.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  6. Richard Vav
    Administrator

    Can you post exactly what you put in your functions file.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  7. David Peralty
    Administrator

    Can you link to your form and show us what you put into your functions.php file?

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  8. Moved the eurosign to symbol_left and tried to throw out the other rules but still it changed to € 3.500,00 instead of € 35,00.
    The link to the form is:
    http://www.oliowerktaan.nl/13-7399/registration/

    add_filter("gform_currencies", "update_currency");
    function update_currency($currencies) {
        $currencies['EUR'] = array(
            "name" => __("Euro", "gravityforms"),
            "symbol_left" => "€ ",
            "symbol_right" => "",
            "symbol_padding" => " ",
            "thousand_separator" => ',',
            "decimal_separator" => '.',
            "decimals" => 2);
    
        return $currencies;
    }
    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  9. Richard Vav
    Administrator

    This isn't happening because of the filter, instead of entering 35,00 as the price can you try entering just 35

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  10. No, it changes into 35,00 when I do so.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  11. Richard Vav
    Administrator

    But isn't that what you want a price of €35,00

    changed to € 3.500,00 instead of € 35,00.

    If you enter 35 Gravity adds the 00 after the decimal separator automatically.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  12. No, when I use the filter in the functions.php it changes to 3.500,00

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  13. David Peralty
    Administrator

    What do you have your product price set to? Double check it once you enable the filter please.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  14. Richard Vav
    Administrator

    If you are still having problems with this feel free to send me a temporary admin username and password to richard@rocketgenius.com and I will take a closer look.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  15. Thanks for your support, I will change it in the currency.php for now, if there is no simple solution.

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  16. Richard Vav
    Administrator

    Olio, just remember that the change will be lost when the plugin updates, again if you want to send a temporary admin username and password to richard@rocketgenius.com I will take a closer look.

    Posted 6 years ago on Thursday July 11, 2013 | Permalink

This topic has been resolved and has been closed to new replies.