PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

How to deactive the visual editor in notifications?

  1. Hey,

    the wysiwyg editor destroys my mail templates after saving a second time. How can I deactive the visual editor in notifications?

    Posted 9 years ago on Tuesday April 17, 2012 | Permalink
  2. David Peralty

    To do that, you'll need to disable it in WordPress. Go to your profile and put a check mark in the Disable the visual editor when writing box. Then when you go to the notifications, you'll no longer have the WYSIWYG, but you'll also not have it when writing a WordPress post or page.

    Posted 9 years ago on Tuesday April 17, 2012 | Permalink
  3. hej. thanks. but to do it seperatly only for GF is not possible? maybe a hack within the plugin code?

    seriously think about that issue: mail templates are very sensible and visual editors brake everything, even when you deactivate the checkmark below the field.

    Posted 9 years ago on Wednesday April 18, 2012 | Permalink
  4. David Peralty

    I'll ask the developers today, but I don't know of a way to control it independently.

    I am not a fan of visual editors either, but if you are having issues with the visual editor for the mail template, then you've probably experienced issues with the visual editor in making WordPress posts, and disabling it for both won't be a bad solution.

    The reason it has the WYSIWYG on that field is that it was highly requested, and instead of developing our own solution, we hooked into what WordPress uses by default. Hence why WordPress' controls determine if it shows up or not.

    Posted 9 years ago on Wednesday April 18, 2012 | Permalink
  5. yeah cool. it is a good and easy way for easy email replies, but if you doing advanced stuff with tables and so on, it is not a good help.

    let me know when you find something out please. it would just help to deactivate the tab "html" and just use the "text" tab.

    thanks ;-)

    Posted 9 years ago on Wednesday April 18, 2012 | Permalink
  6. David Peralty

    Is there a reason why you can't do it for all of WordPress? Do you use the WYSIWYG editor for writing WordPress posts? Once you are done creating the templates, will you be changing them often? If not, you can turn off the WYSIWYG editor, do your stuff and then turn it back on once you are done.

    Posted 9 years ago on Wednesday April 18, 2012 | Permalink