PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

how to solve javascript conflict with Zurb Foundation?

  1. WP 3.6-beta1-24041
    GF 1.7.2
    building a theme with Foundation 4.1.2
    cannot give URL, because in local development

    As soon as I activate Gravity Forms I run into conflicts. I cannot modify any of the forms in the backend and via the frontend no notifications are sent out upon submitting a form.

    The error in the backend says:
    Timestamp: 26/4/13 2:47:35
    Error: ReferenceError: gform_get_tooltip_options is not defined
    Source File: http://domain.local/wp-content/plugins/gravityforms/js/form_admin.js
    Line: 606

    It doesn't matter whether I use the no-conflict mode, doesn't work either way. On top of that the theme loads jquery-noconflict by default and a whole bunch of other scripts.

    I have deregistered the WordPress jQuery version and instead use version 1.9.1 via Google. Foundation also uses zepto. All scripts are properly enqueued.

    My questions is two-fold.
    Does anyone else have similar issues and/or how are these type of conflicts usually solved?

    Posted 8 years ago on Friday April 26, 2013 | Permalink
  2. ok I managed to work out the biggest issues and the forms are once again editable. The problem was that I thought I enqueued everything correctly, but I actually had not...oops.

    now the only thing left is that the admin notification is not sent out. the user receives the notification on his end, but the admin does not.

    where/what should I look at to solve this?

    thanks

    Posted 8 years ago on Friday April 26, 2013 | Permalink
  3. Richard Vav
    Administrator

    You can find information regarding troubleshooting notifications here http://www.gravityhelp.com/documentation/page/Troubleshooting_Notifications

    Regards,
    Richard
    --
    Just another member of the community helping out where I can

    Posted 8 years ago on Friday April 26, 2013 | Permalink
  4. Thanks for your input Richard.

    Resending the admin notification via Forms > Entries works if I send it to a gmail address, but does not work if I send it to an address in my domain.

    Perhaps it has to do with the fact that I'm on a local install, not sure...

    Posted 8 years ago on Friday April 26, 2013 | Permalink