PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

How to stop Gravity Forms Spam filter?

  1. Hey Guys,

    Every now and again, an entry would be marked as SPAM by gravity forms. This means that the notification never gets sent out. Is it possible to turn off the Gravity Forms spam filter?

    Because I think GMAIL takes care of marking things as SPAM on its own. I rely on GF to send me everything that comes through, and I rely on GMAIL to mark things as SPAM if it is spam. From what I note, GF filter hasn't caught any spam on the site. It has only caught a proportion of good stuff. If I don't get notification in my GMAIL, and the user has to wait 2 days to send another query... this makes us look bad.

    Any way to turn this feature off?

    Posted 8 years ago on Wednesday December 12, 2012 | Permalink
  2. David Peralty

    Gravity Forms doesn't have a spam filter. Gravity Forms does hook into things like Akismet and whatnot, so if you are having false positives, please try turning off Akismet for a period to see if it is what is causing that issue.

    Posted 8 years ago on Wednesday December 12, 2012 | Permalink
  3. David, I don't want to turn off Akismet because it would cause a crazy load of SPAM comments to come through. I just need to turn off the spam option from the forms. Do you by any chance have a filter or something that I can use to prevent Gravity forms from hooking into Akismet?

    Posted 8 years ago on Wednesday December 12, 2012 | Permalink
  4. David Peralty

    Here you go, add the following to your functions.php file in your theme folder:

    add_filter("gform_akismet_enabled", "__return_false");
    Posted 8 years ago on Wednesday December 12, 2012 | Permalink
  5. accounting@clusterig.com
    Member

    Right now 100% of my submissions go to SPAM. No matter what. I realized I hadn't gotten any submissions for a while and after digging around, that's the issue.

    Posted 8 years ago on Thursday December 13, 2012 | Permalink
  6. David Peralty

    Glad you were able to figure it out.

    Posted 8 years ago on Thursday December 13, 2012 | Permalink

This topic has been resolved and has been closed to new replies.