PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Image Caption appearing in "Alt" field when image is loaded

  1. DesignWerks
    Member

    I have a form with an image upload and "Caption" selected for Image Metadata, however when the form is completed and an image is uploaded, the text entered into the "Caption" field in the form appears in the "Alternate Text" field of the Image Editor instead of under "Caption", thereby not showing up as a caption in my theme unless I edit and copy and paste it into the correct field.

    Posted 8 years ago on Thursday May 5, 2011 | Permalink
  2. ycb
    Member

    I'm having the same issue -- captions end up as alt text and are not viewable. How to output the caption (Image Metadata) of an uploaded image?

    Posted 8 years ago on Friday August 12, 2011 | Permalink
  3. A bump for this issue.

    It seems odd to me that when you provide a field called "caption" that you don't actually place the text into the post media's "caption" field -- instead of alt text.

    Is there some roadblock that prevents you from addressing that field?

    I'd like for my client not to have to edit the submitted photos just to copy the alt text to the caption field.

    Thanks.

    Posted 7 years ago on Friday January 25, 2013 | Permalink
  4. I did not have the same experience. I added a simple image upload field to a form. You can see the preview of the values I submitted and then what got stored in the media gallery. http://minus.com/mbg8Mgio81bg9k

    Is that not your experience?

    Posted 7 years ago on Friday January 25, 2013 | Permalink