PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Impossible to update or save form

  1. kr2spain
    Member

    Whenever I try to save a form I keep getting this message:

    There was an error while saving your form, most likely caused by a plugin conflict. Please contact us and we will be happy to help you get this corrected.

    I tried deactivating all the plugins and just leaving on the Gravity forms but I still get the same error.

    Any suggestions what can I do to fix this? Thanks

    PS Is not a theme conflict or plugin conflict because it was working some weeks ago perfectly. Plus I did disactivate and activate all plugins and the problem still persisted. Could it be that in the update of the new version of Gravity forms it was not correctly load to my ftp?

    Wordpress version: WordPress 3.0.1.
    Operating System : Linux
    Server : Apache/2
    MySQL Version : 5.1.48-community-log
    PHP Version : 5.2.14

    Gravity forms plugin version: 1.4.3.1

    Just found out that the problem only shows when I duplicate a form and then try to save any changes. When I create a form from sratch I can save correctly the form...

    Posted 9 years ago on Monday October 11, 2010 | Permalink
  2. I think this is a mod_security firewall issue. Here is what you are going to have to do to determine if this is in fact the problem.

    - Create a New Form that consists of only a Single Line text field and a Paragraph text field.
    - Save the Form
    - Edit this new form and add another Single Line Text field
    - Save the Form

    If it works now we need to test a specific field type to determine if it is a mod_security issue.

    - Edit the same form from above
    - Add a Checkbox, Drop Down AND Multiple Choice field to your form.
    - Save the Form

    If it spins... then it is a mod_security firewall issue blocking the AJAX request.

    See this post for details:

    http://forum.gravityhelp.com/topic/forms-not-updating-after-being-saved#post-10305

    You will have to contact your host to adjust your mod_security settings, good web hosts will work with you on adjusting your settings as outlined in the above post from another user.

    Posted 9 years ago on Tuesday October 12, 2010 | Permalink
  3. kr2spain
    Member

    Ok I done all of the above and saving the form worked fine.

    Interesting thing is that after creating a form with all the fields possible I duplicated the form did some modifications and saved it again and it worked!

    So now im wondering if its something to do with just a particular form that is not letting me save it? And yes it is.

    Ok I found the error apparently in the new update you cant insert HTML in the form description like in previous versions...

    But I see now that there is a HTML field so I used that one it worked fine!

    Posted 9 years ago on Tuesday October 12, 2010 | Permalink
  4. We will look into this, you should be able to insert HTML into the description.

    Posted 9 years ago on Tuesday October 12, 2010 | Permalink
  5. diywm
    Member

    I was able to add HTML to the form description successfully.

    Posted 9 years ago on Wednesday October 13, 2010 | Permalink
  6. Just had the same exact issue. Removed the HTML in the description under checkboxes and then it works. Just letting you know.

    Posted 8 years ago on Thursday January 13, 2011 | Permalink
  7. Actually..the HTML block causes the save error as well.

    Posted 8 years ago on Thursday January 13, 2011 | Permalink
  8. Hi jfisher, What version of Gravity Forms are you using? Are you able to consistently recreate this issue on this form? Also, are you able to recreate this issue on other forms or is it limited to just this form?

    Posted 8 years ago on Thursday January 13, 2011 | Permalink
  9. I am using the latest beta release (1.5.rc3.4).
    Any use of HTML (in HTML block or in form descriptions) are causing the:

    "here was an error while saving your form, most likely caused by a plugin conflict. Please contact us and we will be happy to help you get this corrected."

    Error.

    Removing any/all HTML and bam..saves perfectly.

    This is happening on all forms..tried a test with one text field to a more complicated. Any HTML = fail.

    Posted 8 years ago on Thursday January 13, 2011 | Permalink
  10. Next step is to disable all of your plugins and verify that you are still unable to save HTML in descriptions and the HTML field. Let me know how it goes.

    Posted 8 years ago on Thursday January 13, 2011 | Permalink