PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

[resolved] Install Fail (PHP Version Error)

  1. After uploading Gravity Forms we lost the entire site and had to get our web host to delete Gravity Forms from their end. After the Gravity Forms files were deleted the site came back online. The error message we got on our second attempt was:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/harris11/public_html/www/wp-content/plugins/gravityforms/gravityforms.php on line 59

    Any help will be greatly appreciated.

    http://www.harrisonbands.org/www

    Posted 11 years ago on Monday September 27, 2010 | Permalink
  2. This is covered as the 2nd question on our FAQ page:

    http://www.gravityhelp.com/frequently-asked-questions/

    This is a PHP version error. Gravity Forms requires PHP 5 and you are trying to activate it on a site running PHP 4. You need to activate PHP 5 on your web host. This is usually done via a control panel option but you will need to check with your host for specifics on how to do this.

    Posted 11 years ago on Monday September 27, 2010 | Permalink
  3. dedmond29
    Member

    Just wanted to add that I experienced this error - thought that PHP 5 was running - but I did literally have to update PHP to 5 via the CPanel PHP Configuration update.

    I guess that if you've had your site up for a while, even though PHP 5 is available, you still need to update the configuration.

    Posted 11 years ago on Saturday October 2, 2010 | Permalink