PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Installation gone bad

  1. I may have done something wrong right from the get go, because it ain't workin' for me!

    This is what I did:
    Downloaded zip file to my local computer
    Unzipped the file into a directory called gravityforms
    Uploaded the folder to wp-content/plugins/ at my service provider
    Now I have wp-content/plugins/gravityforms/

    Then, I activated it.
    However, cannot make new forms, the fields buttons don't work, etc. The appearance looks like some css missing .. .

    Then, I went to uninstall (before deactivating) and got this message:

    Warning: opendir(/home4/siteodds/public_html/peoplebychoice/wp-content/uploads/gravity_forms/) [function.opendir]: failed to open dir: No such file or directory in /home4/siteodds/public_html/peoplebychoice/wp-content/plugins/gravityforms/gravityforms.php on line 679

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  2. Hello deb, the uninstall error is a known issue that will be fixed in the next release.

    It still uninstalls, it just also returns you an error because the file upload directory Gravity Forms uses does not exist until you actually have a form that uses the file upload field.

    Try re-installing the plugin from scratch and let us know if it works for you.

    Also double check your requirements.

    Gravity Forms requires PHP5+, MySQL5+ and WordPress 2.8+ in order to run.

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  3. Hey,
    I did check requirements - all ok.

    I re-installed from scratch.

    Still, does not work. Buttons don't produce any fields, save new form never actually finishes saving.

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  4. Sorry Deb, just for clarification did you delete the plugin files entirely, reupload and then activate?

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  5. And I should say make sure you run the uninstall (even if it gives you that error) before deleting the plugin from the server and then reuploading the plugin files before activating. This is important because the uninstall deletes the database tables that are created, and in order to install from scratch there needs to be no Gravity Forms tables already in the database.

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  6. ok, I did all that.

    Did the unistall from the forms settings area.
    Then, from plugins I selected delete files.
    Then, I checked to see if all was gone - yes, except the file folder was still there (gravityforms).
    removed the folder
    refreshed everything
    uploaded the folder with all the files

    same result.

    What to do?

    At this point, I would be willing to give you temp access to my wordpress installation . . . maybe you could make it work.

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  7. when I said the file folder gravityforms was still there, I mean it was empty

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  8. Hey deb, temp access would be extremely helpful in debugging this issue. Do me a favor and drop me an email at carl-at-rocketgenius.com with the information and we will do what we can to get this resolved. Thanks!

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  9. This has been resolved. The plugin files that were in the plugin folder were not correct and the folder structure for the plugin was not present. The plugin was deleted and re-uploaded and it worked fine.

    We are working with the customer to determine why the files uploaded were not correct and why the folder structure was not maintained which caused the plugin not to function properly.

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  10. Just want to say I appreciate you working with me to fix the problem. I should have realized that the files when unzipped should not have all been together - of course they should have been in subdirectories. Duh.

    Thanks for doing everything you could to fix this.

    This kind of customer service can make a company go far.

    Best of luck to you.

    Posted 9 years ago on Monday August 31, 2009 | Permalink

This topic has been resolved and has been closed to new replies.