PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Issue with redirect when submitting form, Redirects to blank page

  1. This issue seems like it could be a problem with JetPack playing nicely with GF but I am unsure. I have been having problems when submitting a form where it will redirect to another blank page with the same title. When I get to that page I just see the Jetpack smiley face.

    You can take a look at what is happening here. Note this works when I have my console panel open in chrome.

    Site / Page in question is here: http://healthwarrior.com/tribe/

    Posted 6 years ago on Saturday December 15, 2012 | Permalink
  2. The page listed above is working properly and we have found a workaround for now by disabling Varnish caching.

    I have spent several hours debugging this issue and have found the following:

    1. When disabling Varnish caching this seems to work every time.
    2. With Varnish caching enabled it works only some of the time (mostly when logged into WP admin)
    3. Submission works almost all of the time when the console / inspect panel is open in chrome.
    4. When an error occurs it seems as if the form completely submits then somehow one of 2 things happen:
    a. The entire page that you are on is loaded into the gform element
    b. javascript injects an element into the dom where the only thing visible is the :) from jetpack.

    We run many WP installs with Varnish and have never had this issue until the most recent release of WP + Gravity Forms. Any and all insight you can lend to help work out this issue would be greatly appreciated as I am sure this could become for other users running similar configurations.

    Posted 6 years ago on Monday December 17, 2012 | Permalink
  3. I submitted the sidebar form (Join the Tribe) and was redirected to this page: http://healthwarrior.com/thanks-for-your-submission/

    Seems like it worked OK for me.

    There have been reports recently of conflicts with Jetpack after the update to 3.5 and Gravity Forms 1.6.10.

    Posted 6 years ago on Monday December 17, 2012 | Permalink
  4. Chris - I did a ton of testing with this over the weekend and have narrowed this down to the following. Please see my reply above.

    Posted 6 years ago on Monday December 17, 2012 | Permalink
  5. Hi MMGINC,

    Having exactly the same problem! Only difference is no jetpack but from our testing this isn't a plugin or theme conflict as we've done a fresh install file system and database with no plugins but same problems more over we have exactly the same settings nginx/fastcgi/varnish across 3 different multisite builds but the 4th most recent a fresh install 3.5 multisite is causing what you have outlined and only ever works when logged in. Regardless of the themes and plugins we've even tried to do a completely fresh install with only gravity forms installed but alas. Tried 1.6.5 and 1.7beta 1 but that didn't change anything. Spent two days on this. I read somewhere that the devs have a logging tool maybe they could share it, devs?

    Did you ever find a solution?

    Cheers!

    Posted 6 years ago on Wednesday March 13, 2013 | Permalink
  6. So after the third day of trouble shooting I've decided to disable varnish and well it is the culprit so now just need to figure out the HTTP header submited when gf is submited... Again MMGINC would be great to see how you go on with this... My email is chris@zihzo.com would love to see how you worked around the issue. Whats strange is that its working on all other builds and vcl and conf files are all the same!

    Posted 6 years ago on Wednesday March 13, 2013 | Permalink
  7. Hey All - I am still having this issue on another site. Has anyone been able to resolve this?

    Posted 6 years ago on Wednesday April 24, 2013 | Permalink