PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Issues with strange character where user used a carriage return

  1. RealDesign

    I have a form at :
    Where the user is submitting recipes. We have some users who are using the "return" key inside the longer text boxes. When you export the csv file and then import it into excel, we find a "junk" character has been put where the carriage return is.

    I personally am not able to replicate this, it is my end user that is having the issue. They are using windows and a variety of excel versions including at least 2010 and 2003. However she has sent me a screen shot and I have seen the issue. When you look at the spreadsheet every thing looks fine until you highlight a cell with a carriage return in it and look in the formula bar ... then you see the funny character (it looks like a ? in a black diamond)

    Any ideas on how to eliminate this problem?

    Installation Status

    PHP Version 5.2.17
    MySQL Version 5.1.63
    WordPress Version 3.3.1
    Gravity Forms Version

    Posted 9 years ago on Wednesday August 22, 2012 | Permalink
  2. Normally, this is due to the encoding being used when the CSV is imported into Excel. I find that setting the character set to Unicode UTF-8 takes care of the strange characters in the CSV. I don't have a current version of Excel here to capture the dialog, but this is what it looks like in when importing a CSV.

    Note the first drop down, the Character Set. By default, that was Western Europe (ISO 8859-1) when I first ran the program. I think changing that will probably work for this problem.

    Posted 9 years ago on Sunday August 26, 2012 | Permalink
  3. RealDesign

    Thank-you ... I will see if I can get the customer to get it to work!

    Much appreciated

    Posted 9 years ago on Sunday August 26, 2012 | Permalink