PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Latest update 1.7 cuts off adding forms

  1. infoseek
    Member

    add new form is cut off on top and does not allow me to enter info - if you had a picture U/L i could show you.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  2. Richard Vav
    Administrator

    you can use http://imgur.com to share a screenshot

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  3. infoseek
    Member

    thanks

    http://imgur.com/S8D8jKL

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  4. It'd also be a good idea to run through a theme/plugin conflict test:
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  5. infoseek
    Member

    prior to update this morning all worked very well.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  6. infoseek
    Member

    tried it on another WP installation using the exact same theme and installed plugins

    version 1.6.12 of GF causes NO issues - it's when I upgrade to 1.7 that issues arise

    see pic: http://imgur.com/5U5Oe2A

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  7. I'm having the same issue. All was fine before the 1.7 update.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  8. infoseek
    Member

    FYI: I now remember having installed the "beta" a few months ago and having to remove it due to this same problem.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  9. I've done this. The twenty ten theme fixes the issue. But I'm using MetroStyle Theme. So I ran the conflict check and it still cuts off the form with no plugins on except for GF. I just purchased this at 199 and need my money back if this can't be fixed soon.

    Again, It'd also be a good idea to run through a theme/plugin conflict test:
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  10. If your theme is conflicting, you should reach out to the creator of that theme and notify them so they can correct the issue. When GF works in a default WP theme - it's not the fault of GF. Let us know if your theme creator is unwilling to help.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  11. @infoseek Did you report this issue when using the "beta"? Because if not then we wouldn't have been aware of it.

    If the Twenty Ten theme fixes the issue then this means it's not Gravity Forms that is broken, it's the theme that you activate that is causing the issue to occur. This is called a theme (or plugin) conflict and the issue is related to something your theme is doing that is breaking it. This is something that commonly happens in poorly developed themes, of which there are a TON out there. Including commercial themes.

    Your theme and ALL other plugins you have running output code we have NO control over. They can cause other plugins to not work properly which is exactly what is happening in this instance. This doesn't mean Gravity Forms is broken. It doesn't mean Gravity Forms has a bug. It means the theme is doing something wrong and needs to be corrected.

    Work with our support team and we can take a look at why it is happening. What in the theme is causing the issue and A) if there is anything we can do on our end to work around it or B) what in the theme needs to be corrected to prevent the problem from happening.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  12. All, enable "no conflict" mode on the Gravity Forms settings page and that should do the trick for you. It fixed @rbus's instance.

    No conflict mode basically tries to strip out as much extraneous, external JS files from our admin pages.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  13. infoseek
    Member

    @Carl

    Sorry dude - I don't get paid by you or anyone at GF to be a beta tester.

    I'll just stick with ver 1.6 - no worries

    Mahalo

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  14. @infoseek - just be aware that when WP 3.6 hits, you will need to update to 1.7 to use the form builder in the admin due to jQuery changes implemented by WP.

    Did my suggestion to use the No Conflict mode work for you? In the other user's case it was a theme conflict and turning this on fixed the issue.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  15. @infoseek Your issue is most likely your theme. Although potentially another plugin. But most likely your theme.

    You're blaming Gravity Forms for a problem your theme is causing, meanwhile you are going to continue using this theme despite the fact it has problems. Keep that in mind. This isn't a beta testing issue this is a conflict caused by poor code elsewhere on your site.

    Doing what @Rob suggests and turning on No Conflict Mode would likely resolve the issue. What No Conflict Mode does is it attempts to prevent a theme from outputting scripts in the Gravity Forms admin. But it's not foolproof. There is no way for us to completely prevent this from happening. It's on the theme developer to know what he's doing and output code responsibly. When they don't, it breaks things in the admin such as this.

    You'll need to update before WordPress 3.6 hits otherwise it will stop working properly and it won't be your theme that is breaking it. It will be WordPress that is breaking it due to jQuery updates.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  16. I also was trying to create a new form, when I do the new version open a box in center of screen rest darkens to Name form and description, creates form but I have no way to edit advanced tab like before, and I can't enable SalesForce Web to Lead, like I was able to do in prior. I just upgraded to latest version and am using MySiteMyWay theme Method. Is there another way to get to advanced tab? Is this same issue others are describing?

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  17. The Form Settings are on their own page now. You should be able to see the link on the form editor at the top. This doesn't sound related to this post. Also, we didn't create the SalesForce Add-On so they might need to make an update to their plugin perhaps.

    See this Screenshot

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  18. Yes, I see that. I'm guessing it is an issue with the add-on then.

    Posted 7 years ago on Wednesday April 24, 2013 | Permalink
  19. Just a bit of feedback from a 3rd party on this.

    GF 1.7 update is causing a problem for a few people I know, with a variety of themes.

    On my sites, I've narrowed the problem down to the "Developer Custom Fields" plugin (http://wordpress.org/extend/plugins/developers-custom-fields/).

    Enabling "no conflict mode" DOES fix the problem for me, thank you Rob for the hint.

    Is there any more information available about why it's happening? The screenshot in this thread is exactly the same as my colleagues and I are experiencing. Not all of these sites are running the Developer Custom Fields, so I guess there's some general error that exists in a lot of plugins / themes. If you can offer any advice on what the issue is, it would be really helpful for me and others to be able to feedback to theme & plugin developers for a long-term fix.

    Thanks in advance
    Andy

    Posted 7 years ago on Thursday April 25, 2013 | Permalink
  20. jvgreene
    Member

    I'm also seeing this issue with Thesis Theme 1.8.2.

    Posted 7 years ago on Thursday April 25, 2013 | Permalink
  21. ryanmacdesign
    Member

    Just thought I'd mention that I am experiencing the same problem with the Kallyas Theme. And yes, turning "No-Conflict Mode" on does fix the problem.

    For this theme, it appears that the ThickBox stylesheet, is causing the problem:

    body #TB_window {
    margin-top: -145px !important;
    }

    When I adjust the margin, the "Create a New Form" window displays perfectly.

    On a side note, I very rarely visit this forum, so I thought I'd take the opportunity to say, "Awesome job on GF v1.7.2!!"

    Posted 7 years ago on Thursday April 25, 2013 | Permalink
  22. infoseek
    Member

    yes the no conflict fixed it. thanks

    Posted 7 years ago on Friday April 26, 2013 | Permalink

This topic has been resolved and has been closed to new replies.