PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

mail from noreply is playing havock in horde viewers

  1. anointed
    Member

    I can't seem to figure out where to set my server email address for gravity.

    Basically when a user submits a form of any type, I get an email sent to my admin email box, which I set in the notifications 'send to administrator' box.

    I do get an email at the proper address. However it comes from noreply@website.com instead of a 'real' address.

    The problem makes it so that when I receive the email, I can't read it. My email programs all say that There are no parts that can be displayed inline. and I get an unamed attachment to click on.

    What I want is it to send a proper email that a regular secretary can respond to instead of the can't be displayed inline stuff. It's confusing everyone.

    Is this a pretty simple fix?

    Posted 10 years ago on Monday May 17, 2010 | Permalink
  2. You control the "From" email on the Notifications page for each form. Edit Forms then hover over the form you want and select "Notifications". You setup notifications here, including the From address.

    Posted 10 years ago on Monday May 17, 2010 | Permalink
  3. anointed
    Member

    I have the from email set as prayer@uwcmi.org in the forms notifications settings.
    I have the email being sent as a test to my hotmail account.

    when I receive the hotmail header shows:
    From: Uwcmi (noreply@uwcmi.org)
    Sent: Mon 5/17/10 3:04 PM
    To: mytestaccount@hotmail.com

    Notice it is still saying noreply instead of prayer as the sending from agent:

    I'm only using hotmail for now in order to test things out. Normally I would have it sent to a real admin account. However because it comes from noreply the 'real' admin account does that 'there are no parts that can be displayed'.

    Posted 10 years ago on Monday May 17, 2010 | Permalink
  4. This is a web hosting configuration then. Your web host is forcing the email to be sent using noreply@uwcmi.org for some reason when Gravity Forms uses the built in WordPress send mail function. Some hosts do this for security reasons.

    You may need to install an SMTP plugin for WordPress and configure that to work with your web host. You will need to get specific SMTP configuration information from your host.

    Check out this plugin:

    http://wordpress.org/extend/plugins/wp-mail-smtp/

    We simply rely on the built in send mail functionality of WordPress, so if it isn't working properly... it's a hosting send mail issue.

    A lot of users have success with the above plugin whenever they run into sendmail issues which are always causes by web hosting related configurations outside the control of Gravity Forms.

    Posted 10 years ago on Monday May 17, 2010 | Permalink
  5. anointed
    Member

    thank you so much. I am the host, 'dedicated' so I will install the plugin and configure it. will report back any success or issues found.

    Posted 10 years ago on Thursday May 20, 2010 | Permalink
  6. Hi,

    Was having trouble with this issue (mail not getting through). Set up the suggested plugin, WP Mail SMTP - which works a treat (especially useful debugging/test info)...

    Tried to get SMTP to send through Gmail - but restrictions on my host prevented the necessary SSL encryption. In the end the tech support there fixed the thing by setting my SMTP host as localhost, port as regular 25, no encryption, using SMTP authentication with my cPanel user name and pass as the user/pass. I'm sure it won't be the same for every case - but it's taken a day to get this sorted and I hope this may help somebody else.

    Posted 10 years ago on Monday May 24, 2010 | Permalink