PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Mailchimp only adding contacts randomly... why?

  1. rockstar
    Member

    Hi. I have a site set up to collect details through forms and then add them to Mailchimp. This then sends out a welcome email. The problem is it seems to be choosing which ones to add. Sometimes it works and sometimes it doesn't and I have no idea why? Can you shed any light on it please?

    Posted 11 years ago on Monday July 25, 2011 | Permalink
  2. Are you using the MailChimp opt-in?

    At what point is it choosing which ones to add and which ones not to add? After you receive the MailChimp Email Validation email? Or is the MailChimp Validation email just not arriving at all in some instances?

    I have found MailChimp's Email Validation to be erratic. I've seen it show up in 1 minute, and i've seen it show up 15-20 minutes later.

    Posted 11 years ago on Monday July 25, 2011 | Permalink
  3. rockstar
    Member

    I have it set up to just send the Welcome Email - no double opt in and no opt in conditions.
    They just don't seem to be getting there at all. No addition to MC and no welcome email sent.

    The form is filled in by the user which in turn is linked to the various fields in the feed in Mailchimp.

    So in theory once the form is submitted all the info should be sent to Mailchimp and then the welcome email sent. The problem is that out of 43 entries so far only TEN have decided to add to Mailchimp.

    It isn't a delay issue as some of these are from as far back as the beginning of June and they are still not across...

    Is there anything you can do to check why?

    Thanks for the speedy response by the way, appreciate it.

    Posted 11 years ago on Tuesday July 26, 2011 | Permalink
  4. I have a similar problem, did you resolve it?

    Posted 11 years ago on Wednesday July 27, 2011 | Permalink
  5. If it's working at all, which you've said it works most of the time, that means the code is correct and the integration works. The code itself is either going to work, or it's not going to work. Any issues are going to be related to your web server communicating with MailChimp's web server or with MailChimp's API itself.

    If your web server has a problem communicating with MailChimp, then this could cause an issue as it couldn't send the information to MailChimp. If MailChimp API is having an issue at the time you try sending data to it, this could also cause an issue. It sounds like that is what is happening.

    The *ONLY* other thing API integration related you could look at is if there is anything in common with the entries that weren't added from a field value perspective. Maybe MailChimp didn't like the data that was passed to it. Is there anything those entries have in common as far as that goes?

    Posted 11 years ago on Wednesday July 27, 2011 | Permalink
  6. I think your second para is most likely, one of yesterdays entries simply popped in today. Normally, this happens within minutes. There is still one entry from yesterday that has not synced. I cannot see any common factor or unusual feature in any of the entries that might cause MailChimp not to like them, I will have another look...

    Posted 11 years ago on Wednesday July 27, 2011 | Permalink
  7. The action of sending the data to MailChimp happens immediately when the form is submitted. So if a form is submitted today, but the subscriber doesn't appear in MailChimp until tomorrow... then this is definitely an issue on MailChimp's side.

    This means there is a delay in them processing and updating your data, because there wouldn't be a delay in Gravity Forms sending it because the API interaction happens immediately upon form submission.

    This could be the root of the issue. It's definitely sounding like MailChimp processing issues.

    Posted 11 years ago on Wednesday July 27, 2011 | Permalink
  8. How would I best get this resolved?

    Posted 11 years ago on Wednesday July 27, 2011 | Permalink
  9. I would suggest contacting MailChimp. Use the subscriber that showed up a day after the submission as an example. Ask why a subscriber added via the API one day didn't show up as a subscriber in your list until a day later, and let the know exactly what subscriber. Maybe they can look into it from that.

    Posted 11 years ago on Wednesday July 27, 2011 | Permalink
  10. Thanks for being so helpful - much appreciated

    Posted 11 years ago on Wednesday July 27, 2011 | Permalink