PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

MAMP Pro with Gravity Forms causes WordPress not to load

  1. I recent migrated from using MAMP (the basic version) to MAMP Pro. The main difference for me is that MAMP Pro allows me to use virtual hosts. So instead of accessing a local development site on my Mac via http://localhost:8888/mysitename I can instead setup http://mysitename.dev

    I'm running the exact same plugins in current MAMP as I was in old.

    The site functions fine when Gravity Forms is not loaded. I know it's not a plugin conflict, because I can remove all other plugins from the directory, but if Gravity Forms is included at all, the site does not load.

    The WP_DEBUG constant is set to true in wp-config.php, but no markup is produced when loading any WordPress page.

    The exact same site setup can be pushed to a live server, and even with the exact same plugins being used (and the exact same code) the site will function fine.

    I've tried deleting all of the Gravity Forms tables from the DB, downloading the latest plugin from this site and installing JUST that single plugin and the site still crashes. It loaded fine previously (with no plugins) then crashes as soon as the GF plugin is added to the wp-content/plugins directory.

    This one's got me stumped, even though I'm sure it's something simple. I believe that this is related to Gravity Forms rather than MAMP because every other plugin/WordPress installation that does not use Gravity Forms functions fine.

    Posted 9 years ago on Thursday May 17, 2012 | Permalink
  2. So the site crashes even with Gravity Forms deactivated? Just the files being there causes it to crash? A no errors even with debug enabled?
    This is definitely a strange one. It is hard for me to debug it without seeing what is going on. Is there any way you can replicate this environment somewhere I would be able to access?

    Posted 9 years ago on Friday May 18, 2012 | Permalink
  3. Hi Alex,

    I guess I've narrowed it down to being some sort of plugin conflict. Its just maddening though because I can't seem to identify the source. Additionally, I've been using this stack of plugins for quite some time now without conflict both on localhost and live...

    Posted 9 years ago on Friday May 18, 2012 | Permalink
  4. Here's what I'm finding. The plugin conflict definitely has to do with Gravity Forms. It seems that the installation runs fine if only Gravity Forms is installed/activated. However with GF activated I can only activate a certain number of plugins. However without GF activated I'm able to activate all plugins without issue.

    I suspect that this is actually related to a conflict caused by 3 plugins, but I can't seem to narrow it down further.

    Any advice?

    Posted 9 years ago on Friday May 18, 2012 | Permalink
  5. What you need to do is try to find out what the error is (I am suspecting of a memory error). Normally, setting WP_DEBUG to true would display the error message on the screen instead of a blank screen, but if you still get blank screens with debugging on, try looking for the apache log files.

    Posted 9 years ago on Friday May 18, 2012 | Permalink
  6. David Peralty

    Which three plugins does it seem to be? We are working blind here, so having as much information as possible is super useful to us (continue doing what you have). Can you recount the versions of what you are using in the thread here so we can maybe set up our own test to see if we can replicate the issue?

    Posted 9 years ago on Friday May 18, 2012 | Permalink
  7. Hi Alex,

    Thanks for your advice. It definitely seemed to be an error related to PHP's memory limit. I increased from 32M to 64M in MAMP's php.ini file it seems to have taken care of the issue. Appreciate your helping me work through this!

    Posted 9 years ago on Sunday May 20, 2012 | Permalink
  8. Right on, thanks for letting us know you got it sorted out!

    Posted 9 years ago on Sunday May 20, 2012 | Permalink

This topic has been resolved and has been closed to new replies.