PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Missing stylesheet and javascript after upgrade to 3.2.1

  1. rsigg
    Member

    I'm having a weird issue with my forms styles after my upgrade to WordPress 3.2.1 from 3.1.4 (though I can't say for sure that this hadn't been happening sooner than the upgrade, it's just my best guess).

    The form stylesheet loaded fine previously, but now it seems to be missing. In fact, if you look at this page you can see that none of the Gravity Forms' CSS or JS is loading at all: http://usarivercruises.com/leave-us-a-testimonial/
    These forms were functioning perfectly for a long while, so I don't know what has changed. I certainly haven't made any changes to these forms.
    They are all called via shortcode on their respective pages, "Output CSS" is checked in the settings, and my theme has both wp_head & wp_footer in it (I'm running this on the Hybrid framework).

    I should add that the CSS loads correctly when I preview a form.
    And that I've switched to the TwentyTen and TwentyEleven Themes and the CSS doesn't load in either of those as well.

    Any ideas?

    Posted 10 years ago on Wednesday September 7, 2011 | Permalink
  2. There are no known issues with Gravity Forms and WordPress v3.2.1 so whatever the issue is it's going to be specific to your site setup.

    The first thing you need to do is make sure you are running the latest Gravity Forms release and not an older version.

    The next thing you need to do is test for theme and plugin conflicts by following the instructions here:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Let us know how it goes and we can go from there.

    Posted 10 years ago on Wednesday September 7, 2011 | Permalink
  3. rsigg
    Member

    I just took a stab at the most likely culprit, a plugin I recently activated http://wordpress.org/extend/plugins/footer-javascript/
    Once I de-activated it the CSS and JS load fine.
    Is there a sticky post in the forum about plugins that have known issues that I could add this to?
    I've already added it to the plugin's support forum on Wordpress.

    Thanks for your help.

    Posted 10 years ago on Wednesday September 7, 2011 | Permalink
  4. This isn't technically a conflict. It's not something that can be corrected in either plugin due to the way Gravity Forms handles Javascript. It doesn't support certain JS calls from the footer because the JS needs to be loaded before the form executes. So this is a incompatibility rather than a conflict.

    But we can add it to our conflict list and explain this. We have a list here:

    http://www.gravityhelp.com/question/are-there-any-known-plugin-conflicts/

    Posted 10 years ago on Wednesday September 7, 2011 | Permalink
  5. rsigg
    Member

    Thanks again Carl.

    Posted 10 years ago on Wednesday September 7, 2011 | Permalink