PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Multi-Site Error

  1. Wordpress 1.5.2 and GF 1.7.6 on GoDadday shared....

    No matter if I activate via the network admin or on a specific site I get the error "There was an issue creating your form" when trying to create a form. I opened up PHPMyAdmin and do not see any tables that would relate to GF. Do you know of a reason I would get this error and am I correct in thinking that the lack of DB tables relates?

    Posted 6 years ago on Monday July 8, 2013 | Permalink
  2. David Peralty
    Administrator

    I'm assuming you mean WordPress 3.5.2. Can you go to Forms -> Settings and append &setup to the URL and click enter. Check for tables that say _rg_ in them, as those are Gravity Forms related database tables. Make sure your database has full permissions (write/read/update/delete)

    Posted 6 years ago on Monday July 8, 2013 | Permalink
  3. Woops, yep 3.5.2. It's been a long frustrating day...thanks for the quick reply!

    Anyway, what you suggested didn't do the trick so I've been digging around in the code and printed up this error during the setup process. Now if I can just figure out how to fix it, obviously once I do it will fix my issue.

    $charset_collate = DEFAULT CHARACTER SET utf8 COLLATE latin1_general_ci

    $wpdb->last_error = COLLATION 'latin1_general_ci' is not valid for CHARACTER SET 'utf8'

    Posted 6 years ago on Tuesday July 9, 2013 | Permalink
  4. That was it! I got the DB converted and changed the collation setting in wp-congfig. Good to go now.

    Posted 6 years ago on Tuesday July 9, 2013 | Permalink
  5. David Peralty
    Administrator

    Glad to hear it. Interesting issue. Not one I've seen before. I hope this thread helps others. All my best!

    Posted 6 years ago on Tuesday July 9, 2013 | Permalink

This topic has been resolved and has been closed to new replies.