PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Multiple Images in Upload form, not predetermined where or how many -

  1. Micki
    Member

    I just read... http://www.gravityhelp.com/forums/topic/upload-and-post-multiple-images#post-32751 and trying to figure this out but failing...
    I just set first upload form, very simple but working well except I am lost as far as setting the input field up to allow image upload. I take this back, I am able to insert an image but it ends up at the end of the content. How do I go about formatting the image to, say, end up at the beginning of the content... top/left.
    I am setting this up for multiple people to use and needs for images or not, how many, etc. will depend. Am I trying to do the impossible?
    Thanks for any help you can provide or direction to send a "novice".

    Posted 7 years ago on Thursday September 8, 2011 | Permalink
  2. Can you post a link to your site where this has happened?

    The key for you will be using the content template of the post body.

    Screenshot: http://minus.com/mdCWbDg

    That will allow you to insert any of the images from your form, right into the post, in whatever position you want (before, after, left, right.) Does that help?

    Posted 7 years ago on Thursday September 8, 2011 | Permalink
  3. Micki
    Member

    I would love to give you the url but it is in a members section and you will need to login. i am happy to give you access but would prefer not posting it here. Is there a way I can send it to you another way?
    Oddly, the text that i am entering is not showing, only one photo... the first one I upload. It does not show it has inserted, thus only allowing one.
    My first few attempts showed the text.
    I do not have the option in the drop down that you are showing in your screenshot, "photo of the results". The only reference to an image is "Post Image" and I do have Create Content Template checked. I do not see how to upload a screenshot for you to see.
    Thank you

    Posted 7 years ago on Thursday September 8, 2011 | Permalink
  4. Micki
    Member

    I went ahead and deleted the form and am starting over. You mention that I need to use the content template of the post body. when I do this it shows a drop down for the "category to post to" in the settings. I want the option to post to whatever category I assign the content to, so now I am really confused. help? I know this should not be difficult.... or direct me to the docs that support this, I did look but must have missed it... thank you

    Posted 7 years ago on Thursday September 8, 2011 | Permalink
  5. Micki
    Member

    ok, based on your info reply in http://www.gravityhelp.com/forums/topic/upload-and-post-multiple-images#post-32751 , this looks to me like specific areas on page to add images. IF I set this up and there is not an image uploaded, will it show a broken image link? I am thinking that there is no way to have random positioning based on individual uploaded posts? Can someone answer something. I know that you are probably rolling your eyes and once i understand, I will understand.

    i still do not see the option 'photo of results", is this a result of code you entered?
    thank you

    Posted 7 years ago on Thursday September 8, 2011 | Permalink
  6. @Micki If you select a default category when editing the Post Body that is the category the post will be assigned to. If you add a Post Category field to your form, it will use that for the category.

    Posted 7 years ago on Thursday September 8, 2011 | Permalink
  7. Micki
    Member

    yes, thank you, I figured out the category thing. Any ideas on the image upload question? or am I writing the question to where no one understands what i am asking?

    Posted 7 years ago on Thursday September 8, 2011 | Permalink
  8. On my form, "Photo of the result" is the name of the input field where I allowed the image upload. Once Gravity Forms knows there's an image field, and you select that field from the drop down, you will see the image options as I show in the screenshot.

    This is the form where I used that "Photo of the result":
    http://guitar.chrishajer.com/submit-a-recipe/

    Are you using an "Image" field from the "Post Fields" section? If so, save the form, navigate to another part of your wp-admin, then come back. Sometimes with the AJAX update in the form builder, the fields don't show up in the drop down.

    If you want to, you can export your form as it is and email it to me at chris@rocketgenius.com and I will install it and see what's up.

    Posted 7 years ago on Friday September 9, 2011 | Permalink
  9. Micki
    Member

    ok, thank you, I sent it off.

    Posted 7 years ago on Friday September 9, 2011 | Permalink
  10. Micki, I just sent you an email.

    I was able to delete the post image field, save the form, insert a new post image field, then recreate the content template by inserting the new fields via the drop down, then it worked. For one image (there was only one post image field in the form you sent me.)

    To add multiple images, I would add all the post image fields, then save the form, and reload the form builder, to ensure the proper fields are available in the drop down for the content template.

    Posted 7 years ago on Tuesday September 13, 2011 | Permalink

This topic has been resolved and has been closed to new replies.