PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Multisite notification to admin fails for one site, but the other is fine

  1. joonymobile
    Member

    Multisite, gravityform 1.6.4.4, wordpress 3.3.2, Google App

    I am experiencing some strange behaviours from GF.
    Yes I have searched the forums but there isn't any clear solution to this.

    my forms and notifications(both user and admin) in http://www.mysite.com work fine
    but the notifications(okay for user, but the admin notification doesn't work) in http://www.mysite.com/sub doesn't work correctly

    To say that again,
    When the form is submitted, "User notifications" is okay for both http://www.mysite.com and http://www.mysite.com/sub
    BUT "Admin notifications" only works in http://www.mysite.com AND doesnt work for http://www.mysite.com/sub

    I tried to use the smtp plugin as one of the GF admins suggested but it only gets my google app account banned.

    If I need to tell the support team at my hosting server, how should I be telling them?
    ------------------

    I want to add another info since no one has replied.
    Everything in the root directory works fine "www.mysite.com"
    but my subsite "www.mysite.com/sub" doesn't even send general notifications by Wordpress.
    Is it because the email server think I am sending emails internally? like http://www.gravityhelp.com/forums/topic/one-site-two-forms-only-one-sends-notifications-to-admin

    Posted 7 years ago on Sunday May 27, 2012 | Permalink
  2. joonymobile
    Member

    Hi Support Team,

    will I get a reply? Please let me know.
    I heard GF support is awesome though. Please don't disappoint aspirants

    Posted 7 years ago on Thursday May 31, 2012 | Permalink
  3. David Peralty
    Administrator

    You were correct with the link you posted. Take some of the details from that thread and talk to your web host and they should be able to sort it out.

    The reason we don't support notifications is because we just pass the data to wp-mail.php (WordPress' built-in e-mail function) and that's it. Almost always it is a server or e-mail configuration issue, and not a Gravity Forms issue (unless the e-mail address is wrong or you are trying to do something special).

    Posted 7 years ago on Thursday May 31, 2012 | Permalink
  4. joonymobile
    Member

    Thank you David for the reply! :)

    This is what I got from my server support team.

    ---------------------
    I understand the situation that your plugin provider described, but that
    isn't the case here. Your web server does correctly see that your MX
    records point elsewhere:

    root@www4.g1# host -t mx example.com
    example.com mail is handled by 25 ALT2.ASPMX.L.GOOGLE.com.
    example.com mail is handled by 50 ASPMX2.GOOGLEMAIL.com.
    example.com mail is handled by 50 ASPMX3.GOOGLEMAIL.com.
    example.com mail is handled by 10 ASPMX.L.GOOGLE.com.
    example.com mail is handled by 25 ALT1.ASPMX.L.GOOGLE.com.

    Do you have an example of a message that the server should have delivered
    externally but didn't? I'll need the email address it was supposed to go
    to and the timestamp of the message.
    -------------------
    Here is what I sent them

    --------------------

    The problem is http://www.example.com notifications work fine, but http://www.example.com/sub and paypal notifications don't work correctly.

    I have contacted support team from my premium plugin called "Gravity Forms" and they told me to say this to you.

    ---------
    What is happening is your web server thinks it hosts your email so it's trying to send the email internally, but because your email isn't hosted locally it's not sending the mail out remotely.

    Your web server doesn't know it isn't hosting your email so it is trying to route it internally rather than sending it out remotely so it never gets to your Google apps hosted email account.

    Here is the official support article from Google on this issue:

    http://www.google.com/support/a/bin/answer.py?hl=en&answer=55299

    Here is a more specific answer to this in the Google Apps help forum:

    http://www.google.com/support/forum/p/Google+Apps/thread?tid=179686d4bd75d3d2&hl=en

    To sum it up you need to tell your web server that your email is hosted remotely so it will send it remotely. Contact your web host to find out specifics on how to do this. It's typically a control panel settings change.

    Explain to them the email for your domain name is hosted with Google Apps and email sent via PHP on your web server is not arriving to those accounts but it is arriving to accounts not associated with your domain name. They should be able to assist you. You can show them the first Google link above which should provide them with enough information to assist you in correcting the issue.

    So, I believe what we need to do is to change the e-mail routing to "REMOTE MAIL EXCHANGER", not the "Automatically Detect Configuration: Local (recommended)". I changed the MX record but I am not sure why it is behaving this way..

    Can you please take a look at see what's wrong?

    --------------

    I think they are also saying that it's not their issue. Please help us solve this problem :(

    Posted 7 years ago on Wednesday June 6, 2012 | Permalink
  5. A Priority Support ticket exists for this issue. I am closing this forum post and it will be handled via Priority Support.

    Posted 7 years ago on Friday June 8, 2012 | Permalink

This topic has been resolved and has been closed to new replies.