PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Network Solutions - php.ini ?

  1. Hi,

    Any known issues with NetworkSolutions. Gravity forms working on staging site (Bluehost) perfectly, but when I moved to live server (NetworkSolutions) it stopped sending notification/confirmation emails.

    Staging: http://creativecollab.net/wescap/contact-us/

    Live: http://www.wescapgroup.com/contact-us/

    Form entries are being captured - I see them under "Entries" in the admin, but confirmation/notification emails aren't being sent.

    Here is the php.ini file they have on server - which I'm guessing is the culprit:

    ;
    ;  Including file: /data/templates/web/user/domain.com/cgi-bin/php.default.ini
    ;
    
    upload_tmp_dir = /data/tmp
    asp_tags = On
    register_globals = On
    safe_mode = Off
    upload_max_filesize = 25M
    post_max_size = 25M
    output_buffering = 1024
    mime_magic.magicfile = /usr/share/misc/file/magic.mime
    memory_limit = 32M
    include_path = .:/usr/services/vux/lib/php
    disable_functions = shell_exec,passthru,exec,system,pcntl_exec
    allow_url_include = 0
    allow_url_fopen = 0
    sendmail path = /usr/sbin/sendmail
    extension_dir = /usr/services/vux/php5/lib/php/extensions
    zend_extension = /usr/services/vux/php5/lib/php/extensions/ioncube_loader_lin_5.2_real.so
    zend_extension = /usr/services/vux/php5/lib/php/extensions/ZendOptimizer_real.so
    
    realpath_cache_size = 64K
    realpath_cache_ttl = 600
    
    ;
    ;  Suhosin Configuration
    ;
    
    ; Disable suhosin for now
    ;extension = suhosin.so
    ;suhosin.simulation = On
    ;suhosin.executor.disable_eval = On
    ;suhosin.executor.eval.blacklist = popen
    
    session.gc_probability = 1
    session.gc_divisor = 100
    session.gc_maxlifetime = 3600
    
    date.timezone = America/New_York
    
    error_reporting = (E_ALL & ~E_WARNING & ~E_DEPRECATED & ~E_NOTICE)
    
    ;
    ;  User-based Defaults
    ;
    
    session.save_path=/data/12/1/71/113/1071928/user/1109442/cgi-bin/.php/sessions
    
    ;
    ;  Including file: /data/templates/web/user/domain.com/cgi-bin/php.override.ini
    ;
    
    error_reporting = (E_ALL & ~E_WARNING & ~E_DEPRECATED & ~E_NOTICE)
    Posted 9 years ago on Tuesday May 14, 2013 | Permalink
  2. PS. I added line 18:

    sendmail path = /usr/sbin/sendmail

    Posted 9 years ago on Tuesday May 14, 2013 | Permalink
  3. David Peralty

    If PHP sendmail isn't working and your host won't help you resolve it, maybe try one of the SMTP plugins for WordPress? You can find more details here: http://www.gravityhelp.com/documentation/page/Troubleshooting_Notifications

    Posted 9 years ago on Tuesday May 14, 2013 | Permalink
  4. Bluehost doesn't allow the use of 3rd Party SMTP. I'm struggling with this since the update to 1.7.

    It seems that Bluehost is a stickler for proper headers: https://my.bluehost.com/cgi/help/206

    Can someone please advise a suggestion?

    Posted 9 years ago on Wednesday June 5, 2013 | Permalink
  5. David Peralty

    Are you sending from an e-mail address that exists on your server?

    Posted 9 years ago on Wednesday June 5, 2013 | Permalink