PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

New Form dialogue goes 'off screen'

  1. After upgrading to 1.7 I can't create new forms anymore... the dialogue is placed in such a way on the screen, that only the description is visible, so I can't complete the form.

    Tested it on Chrome and FireFox, using Linux/Ubuntu

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  2. Richard Vav
    Administrator

    This happens when there is a theme or plugin conflict, you can normally rectify it by going to the Gravity Forms general settings page and enabling 'No-Conflict Mode'. If that doesn't work you will have to go through the theme/plugin conflict troubleshooting steps.

    Regards,
    Richard

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  3. Yes, it worked... only strange that the 1.6.x version worked normally and from 1.7 I need the non-conflicting mode...

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  4. Richard Vav
    Administrator

    I am glad that worked for you; in 1.6.x forms were created in a different way so the conflict wouldn't necessarily have been evident, if you have time you should probably temporarily disable no-conflict mode and then carry out the plugin/theme conflict testing to find the culprit.

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  5. I just ran into the same glitch. Since latest updates the "new form overlay" does not function right.. When disabling the line:
    body #TB_window {
    margin-top: -145px !important;
    }
    in Firebug, the form shows normally.
    The no conflict mode solution works, but its the first time I have ever needed to tick that box in over a few hundred installs...

    @richardnav what do you mean by "plugin/theme conflict testing" for now the culprit is GF :-)

    I also discover just now that the notification to the user who has submitted the form has stopped working.. grr.

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  6. Paul,

    No Conflict mode isn't meant to no conflict our own code, it's to prevent other themes and plugins JS from getting output on our pages in the admin.

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  7. What do you mean by "incorrect"... ?
    If I check another install with GF I see the same css line, the TB_window is from ThickBox that seems to be used by GF to display the new form dialog in a LightBox overlay.
    That is not functionality that is installed by me, but by GF...

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  8. Paul,

    Apologies, I should have been more specific, when this does not work correctly it's generally because another theme or plugin is also using thickbox and their placement modifies that selector positioning. By enabling no-conflict mode, it instead uses our declaration (positioning) on our pages of the admin instead of globally.

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  9. @richardnav, Sorry I had overlooked the link on your theme/plugin troubleshooting guide.

    Sure you can work that way... but that is more the way when you have a new site. Now the site is already up and running and did not have problems with GF sofar.
    Recently there has been a surge of updates of GF, so at first glance its more likely that the changes in GF are the cause of the problem.

    It had been a relative trouble free time with the updates, so maybe I click the update button too easy now?

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  10. I'm having the same problem. When creating a new form, the modal dialog positions the content so high up that it starts about halfway through the "Form Description" label. There is no way to set a title for the form.

    I tried turning on the "No Conflict" checkbox but it doesn't help. I've cleaned my browser cache and even turned off the cache, to no effect. I've disabled all but the vital plugins and there is no change.

    I also noticed that the "Add Ons" module comes up with an error message that Add Ons are currently not available. Not sure if that's related, but letting you know in case there might be a connection. I'm running GF 1.7.2 and WP 3.5.1

    Posted 8 years ago on Thursday May 30, 2013 | Permalink
  11. Richard Vav
    Administrator

    Adwiz,

    First you should update to Gravity Forms 1.7.5 then as per the theme/plugin conflict testing steps you will need to disable ALL plugins to find the conflict. If you only disable some and the problem remains then that suggests that it is one of the plugins you left active that is causing the issue.

    Regards,
    Richard

    Posted 8 years ago on Friday May 31, 2013 | Permalink
  12. Hello,

    I've found that including wp_enqueue_script('media-upload'); in functions.php causes the problem, exactly as others are describing.

    I had been hooking it into admin_init to give all my custom backend pages access to the new Media Manager, instead of restricting it to my pages only. I'm sure there are plugin/theme authors making the same mistake.

    Hope this helps someone!

    Posted 8 years ago on Friday May 31, 2013 | Permalink