PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

New server location, not receiving notifications

  1. stonerbunting
    Member

    I've dug through what seems to be a dozen posts on this topic, but haven't been able to find a solution for my specific issue.

    We recently moved a client's website to a new host and, since then, they have not been receiving their notification emails. Prior to the move everything worked fine. The bizarre part of this is that before AND after the hosting switch I continue to receive the notifications without issue.

    What on the new server would be preventing my client from receiving the emails, but allow me to continue to receive them without issue?

    Thanks in advance.

    matt

    Posted 7 years ago on Wednesday February 13, 2013 | Permalink
  2. As far as notifications go, Gravity Forms does not actually send the email notifications. That is 100% handled by your web server. Gravity Forms uses the WordPress wp_mail() function, a built in WordPress function, to ask your web server to send the email notification.

    This can happen when you do things such as configure the Send From address of email notifications to an email address that does not use the same domain name as the web site itself. Also, sometimes they can get spammed.

    After that, it is entirely up to your web server to reliably send the email. Unfortunately, many web hosts are simply unreliable at handling email properly when sent via PHP. This results in unreliable performance.

    The most reliable way to configure WordPress to handle sending email is going to be to use SMTP. You would do this by installing the WP Mail SMTP plugin and then contacting your web host to get the appropriate SMTP settings. You would then need to configure the Send From of your notifications so that it uses an address associated with that SMTP account.

    http://wordpress.org/extend/plugins/wp-mail-smtp/

    You can also test for theme/plugin conflicts, as we have seen plugins block notifications before:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    More reading here:
    http://www.gravityhelp.com/documentation/page/Troubleshooting_Notifications

    Posted 7 years ago on Wednesday February 13, 2013 | Permalink
  3. stonerbunting
    Member

    Thanks for the feedback. Just following up with my solution -- I ended up tweaking Email Routing settings within cPanel. I changed my routing to Remote Mail Exchanger within cPanel and that did the trick.

    Posted 7 years ago on Wednesday February 13, 2013 | Permalink
  4. Right on, glad you got it working. Thanks for posting your update as well.

    Posted 7 years ago on Wednesday February 13, 2013 | Permalink

This topic has been resolved and has been closed to new replies.