PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Next button not working

  1. Next button as well as the submit button do not work at all. When clicking either of these buttons it simply refreshes the page and removes all previous selected info.

    WordPress version 3.4.2

    Posted 7 years ago on Thursday October 18, 2012 | Permalink
  2. Please post a URL to your form page so we can check this out. This is going to be something specific to your installation so we need to see your form to be able to help.

    Posted 7 years ago on Thursday October 18, 2012 | Permalink
  3. http://www.kstatecollegian.com/apply/

    Posted 7 years ago on Monday October 22, 2012 | Permalink
  4. It looks like you have quite a few JS errors on that page. Can you please test for plugin/theme conflicts by following the instructions here:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 7 years ago on Monday October 22, 2012 | Permalink
  5. I have tested both the theme and plugin, even with the theme changed and all of the plugins disabled the problem still persists.

    Posted 7 years ago on Tuesday October 23, 2012 | Permalink
  6. Does the form work as intended in the formbuilder preview window?

    Posted 7 years ago on Tuesday October 23, 2012 | Permalink
  7. It does not. Is there a reason why it is acting like this.

    Posted 7 years ago on Tuesday October 23, 2012 | Permalink
  8. Hmm - thats' pretty strange - sounds like it could potentially be a host/server/permalink issue perhaps. Let's try something here...

    Duplicate the form (unless you have a non-multipage form available already) and make the duplicated form a single page, so remove the page breaks. Fill the form out and submit it and see if it submits successfully and creates an entry.

    Posted 7 years ago on Tuesday October 23, 2012 | Permalink
  9. I have updated the form and removed all the page breaks. The form still does not want to submit. In fact clicking the submit button at any time, even when the form has not been completely finished, just refreshes the page and removes all preselected options.

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  10. This is something specific to your installation. Please export this form as XML and email it to chris@rocketgenius.com and I will install it and see if it submits for me.

    This is normally due to a theme or plugin conflict, but you have tested for those.

    It could also be a permalink issue. Can you try visiting the permalinks setting page in wp-admin and just resave the permalinks you are using now. That might help. If not, and you do not have any theme or plugin conflicts, please export the form and email it to me so I can check it out on my server.

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  11. form sent thank you for your help.

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  12. I received your form and installed it on my server and the form submitted just fine. First with validation errors because I did not fill in everything, then with all the data filled in. After submission I received this confirmation text: "Thank you, your application has been submitted successfully!"

    There is something going on with your installation. Can you go back to step one and check for theme and plugin conflicts by following these instructions: http://rkt.gs/testing

    Thank you.

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  13. Thanks for getting back to us so quickly Chris. Unfortunately we are still unable to get this single form working. We created a new form completely different than this one and it worked right away. We seem to be having problems with just this form.

    Posted 7 years ago on Friday October 26, 2012 | Permalink
  14. David Peralty
    Administrator

    Have you written any custom functions in your functions.php that might affect Gravity Forms?

    Posted 7 years ago on Friday October 26, 2012 | Permalink
  15. I wanted to let you know that we fixed the issue. There was one custom field that had a picture in it that was messing everything up on our site. Thank you all for the fast replies.

    Posted 7 years ago on Tuesday October 30, 2012 | Permalink
  16. Thank you for the update.

    Posted 7 years ago on Wednesday October 31, 2012 | Permalink

This topic has been resolved and has been closed to new replies.