PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

NEXT Button not working in IE

  1. The form works real nice in Firefox, Chrome, Safari but not IE (7,8,9). In particular the NEXT button seems to stop working in IE. I have read many posts in this forum and have applied or at least I though I applied many of the suggestions (disabled / deactivated other plug-ins).

    I have the Gravity Form installed on a ThemeID Responsive theme. Any suggestions would be appreciated. Thank you in advance.

    Here is a link to my site.

    http://symposium.furniturefirst.coop/member-registration

    Ryan

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  2. krshoffner
    Member

    I am not a moderator here, but I did just test in IE 9, as well as using backwards compatibily modes of their F12 tool back to IE 7, and the "Next" button displayed without probably at the bottom of your form.

    Did you get it working?

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  3. I suspect the issue is the older version of jQuery and WordPress. The form worked fine for me as well, but for best compatibility, we recommend staying up to date with WordPress and Gravity Forms. I see you have Gravity Forms 1.6.11 but WordPress 3.4.2. Is there anything preventing you from upgrading to WordPress 3.5? If you theme and plugins are all compatible with WordPress 3.5, I would recommend upgrading and checking the form again to see if it works properly in all browsers.

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  4. I just upgraded WordPress to 3.5. My issue is that the NEXT button, when clicked on, will not proceed to the next step of the form. It just remains on the same page.

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  5. You have a JavaScript error on that page which is likely causing the Next button to stop working. Please resolve this error and we will check again.

    Timestamp: 1/15/2013 12:54:14 PM
    Error: downloadable font: download failed (font-family: "Pala" style:normal weight:normal stretch:normal src index:1): status=2147746065
    source: http://symposium.furniturefirst.coop/wp-content/pala.TTF
    Source Code:
    @font-face {   font-family: "Pala";   font-style: normal;   font-weight: normal;   src: local("?"), url("http://symposium.furniturefirst.coop/wp-content/pala.TTF") format("truetype"); }

    Also, please test the form in the Form Preview and see if it works there. If it does, and fixing the above error does not resolve the live page, please proceed by checking for theme and plugin conflicts by following these instructions http://rkt.gs/testing

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  6. Okay... I removed the fonts that was causing the error and the problem still persists.

    1. I installed Twenty Ten Theme and the issue still persists.
    2. I then deactivated all plug-ins except Gravity Forms and the issue still persists.

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  7. Does it work correctly in IE when you use the form preview?

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  8. Also, can you visit the permalinks options page on your site and just resave the permalink structure you have now? Maybe the rules just need to be flushed.

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  9. I tried the form preview and the issue still persists. I also tried your second recommendation and resaved the permalink structure and the issue still persists.

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  10. Thank you for all your troubleshooting. Can you please export that form as XML (Forms > Import/Export > top center menu items "Export Forms") and email it to me at chris@rocketgenius.com - I would like to install it and take a look on my server. Thank you.

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  11. Just sent it. Thank you.

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  12. Please remove the print functionality (remove the complete form tag in the HTML block) in field 58. I removed that from the form you sent and I was able to advance to the next page using IE9 (actually, I got validation errors like I did with other browsers when submitted with no fields filled in.) Nested form tags like that (your form inside the Gravity Form) are not valid.

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink
  13. That did it! Wow... Thank you.

    Posted 8 years ago on Tuesday January 15, 2013 | Permalink

This topic has been resolved and has been closed to new replies.