PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

No Confirmation or Error Messages after Submit

  1. We've got a form that when you hit "submit" doesn't show any sort of confirmation or error message. If it is filled out, it will send the notifications, but we are puzzled as to what is causing the issue. We've checked the jQuery no conflict option and tried varying fields, but unable to figure out what we've done wrong. The form is embedded using the do_shortcode method in the template file. We've tried the form on other pages and it seems to work. We just need it to work here.

    The site is here: http://3.nms3.com

    The form is under the contact tab. All help is appreciated.

    Posted 8 years ago on Thursday October 11, 2012 | Permalink
  2. You might need to enqueue scripts/styles, see the bottom of this page:
    http://www.gravityhelp.com/documentation/page/Embedding_A_Form

    Posted 8 years ago on Thursday October 11, 2012 | Permalink
  3. I placed the code in the header file, but no change in the result.
    I also tried placing a loop around the shortcode and then the function call with no success either.

    any other suggestions?

    I truly appreciate the help.

    Posted 8 years ago on Saturday October 13, 2012 | Permalink
  4. Does the form work in the form preview? And does the form work if you embed it into a WordPress page without using the tab functionality?

    How does the form get embedded in the tab section right now?

    Also, you have a pretty custom front page there. Does the theme include the proper call to wp_head() in the header.php and wp_footer() in the footer.php?

    Posted 8 years ago on Sunday October 14, 2012 | Permalink
  5. The form works on other pages and the preview.

    It's a custom page template, but built off of a Woo Themes template and has both the call to the head and foot files.

    Posted 8 years ago on Thursday October 18, 2012 | Permalink
  6. Ok. I've gotten the errors/notifications to show, but only when Ajax is off.

    When Ajax is off, the functions work, but it refreshes the page, so you have to re-open the tab. If Ajax is on, there is no confirmation or error. It is this way when I embed the form on another page as well (I'm using the Woo Themes Canvas theme which we've never had this issue with before).

    The scripts are enqueued above the wp_head() and the form is embedded with a function call.

    Posted 8 years ago on Thursday October 18, 2012 | Permalink
  7. Any thoughts or ideas?

    Posted 8 years ago on Friday October 19, 2012 | Permalink
  8. Biz yourself
    Member

    I am having similar problems and working through issues as I have just installed gravity forms. How did you turn Ajax off so i can trial this? I have seen it before while working on forms but can not find it now. Thanks you.

    Posted 8 years ago on Monday October 22, 2012 | Permalink
  9. You can turn it off in the shortcode or in the call for the code.

    Posted 8 years ago on Tuesday October 23, 2012 | Permalink
  10. same here I'm using an ajax form and it submits to the database ok but doesn't show the confirmation message anywhere, if I don't use ajax it shows the confirmation... Can someone please help

    Posted 8 years ago on Friday November 16, 2012 | Permalink
  11. @mimoymima, please start a new topic for your issue, and post a URL to the page with the form where we can see the problem. Thank you.

    The topic has been closed because there are too many individual issues to handle in one support topic. Please feel free to open your own topic with a clear explanation of the problem, and include a URL to the page on your site where the problem with the Gravity Form can be observed.

    Posted 8 years ago on Saturday November 17, 2012 | Permalink

This topic has been resolved and has been closed to new replies.