PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

No email for a single form

  1. I have created a form and posted it to this page: http://arbourrealty.com/test-form/

    I'm able to receive notifications from all my other forms, but this one. I have tried duplicating the form, but that does not work. I have mimicked the notification settings of the forms that do work and that did not help. My entries show up if I log into the dashboard, but I am not receiving them via email.

    Posted 5 years ago on Wednesday July 10, 2013 | Permalink
  2. David Peralty
    Administrator

    Please begin troubleshooting by installing our logging add-on. It's available for download here: http://www.gravityhelp.com/downloads/#Gravity_Forms_Logging_Tool

    Upload and activate that like any WordPress plugin, then navigate to Forms > Settings > Logging, and activate logging for Gravity Forms and the add-on you're trying to troubleshoot. Then, test your forms, and return to this page. After log files have been created, there will be a link to them next to the drop down where you configured the log level.

    Posted 5 years ago on Wednesday July 10, 2013 | Permalink
  3. I have done as you asked. Is there something within the log I should be looking for?

    Posted 5 years ago on Wednesday July 10, 2013 | Permalink
  4. David Peralty
    Administrator

    An error relating to sending a notification message would be helpful, any errors at all would be useful. What are you seeing in your log file?

    Posted 5 years ago on Wednesday July 10, 2013 | Permalink
  5. Here is what I am seeing:

    http://pastebin.com/VqS7wJ00

    Posted 5 years ago on Thursday July 11, 2013 | Permalink
  6. David, do you have any suggestions?

    Posted 5 years ago on Friday July 12, 2013 | Permalink
  7. David Peralty
    Administrator

    The log you have shows that the e-mail was sent to wp-mail.php and was processed successfully. You'll have to check with your host to see what's going on. They can look at that log as well. Ask them to check for error logs on the server regarding wp-mail.php or if they have any blocks/settings that would restrict you from sending that e-mail.

    Also, you might want to check the logs created on the working forms just to confirm they give you the same result (even though that's what you are experiencing) just so we rule everything out.

    Lastly, try deleting the notification and recreating it and see if that solves the problem. Glitch in the system somewhere that the log isn't picking up...

    Posted 5 years ago on Friday July 12, 2013 | Permalink
  8. Thanks. I'll try that. The other thing I noticed (and I have tried two different browsers) is that I can not enter anything into the notification message field. There is a drop down on the right side and when I select an item, it will not show up. Basically nothing happens.

    Posted 5 years ago on Friday July 12, 2013 | Permalink
  9. Richard Vav
    Administrator

    Can you try enabling 'No-Conflict Mode' on the Gravity Forms general settings page, if that doesn't help you will need to test for a plugin/theme conflict.

    Posted 5 years ago on Friday July 12, 2013 | Permalink
  10. I was able to identify the conflict that was causing my inability to edit the message content. That is fixed.

    Unfortunately, I am not receiving email notifications for any of my forms at this point. I went from not being able to receive email notifications from the new forms to not being able to receive them for any of my Gravity Forms. Are there any other possibly solutions you can recommend?

    Posted 5 years ago on Tuesday July 16, 2013 | Permalink
  11. Installing SMTP mail for WP, fixed it.

    Posted 5 years ago on Wednesday July 17, 2013 | Permalink
  12. David Peralty
    Administrator

    Glad to hear it. You might still want to put in a ticket with your host regarding PHP sendmail issues. All my best!

    Posted 5 years ago on Wednesday July 17, 2013 | Permalink

This topic has been resolved and has been closed to new replies.