PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

No more form submissions

  1. panart
    Member

    Hi,

    Since a week we do not get any form submissions anymore, and we didn't change anything.
    How is this possible.

    Kind regards,

    Sven den Otter

    Posted 8 years ago on Wednesday February 6, 2013 | Permalink
  2. panart
    Member

    Hi,

    The forms still do not work. Can anyone from the support forums take a look at this.
    Kind Regards,

    Sven den Otter

    Posted 8 years ago on Monday February 11, 2013 | Permalink
  3. We will need a URL to the page on your site where the form is located.

    When a form is submitted, is the entry stored, and you are just not receiving email notifications?

    Did you make any changes to your site recently?

    Posted 8 years ago on Tuesday February 12, 2013 | Permalink
  4. panart
    Member

    Hi Chris,

    Thank you for your reply. Well at first I though the submitted forms didn't get stored, but I recently found out they are all marked as spam. The URL is http://www.glansmagazine.nl.

    How can I prevent the entries from being marked as spam?

    Thank you in advance.

    Posted 8 years ago on Tuesday February 12, 2013 | Permalink
  5. If you are using Akismet to prevent comment spam, your form submissions will be filtered through Akismet as well. You can prevent that from happening by using the gform_akismet_enabled filter:

    http://www.gravityhelp.com/documentation/page/Gform_akismet_enabled

    That code to disable Akismet for your form submissions will go in your current theme's functions.php.

    Posted 8 years ago on Wednesday February 13, 2013 | Permalink
  6. burkeb03
    Member

    I just ran into this same issue it seems. I've implemented the code above at the bottom of my functions.php (ensuring that there are no blank lines and php tags are closed appropriately) , and now receive the following message in the Entries page:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'disable_akismet' not found or invalid function name in /home/content/24/9722324/html/wp-includes/plugin.php on line 173

    With that, my emails are being delivered again, but the same error message also briefly displays upon submitting the form on the public side.

    Posted 8 years ago on Thursday February 21, 2013 | Permalink
  7. David Peralty

    Try the following example:

    <?php
    add_filter("gform_akismet_enabled", "__return_false");
    ?>
    Posted 8 years ago on Thursday February 21, 2013 | Permalink
  8. twistystraws
    Member

    http://blog.brethertons.co.uk/client-satisfaction-survey

    I'm having a similar problem to this, and I assume it's linked to Akismet. After clicking submit, the form entry is submitted, but there is no notification message displayed on screen, the spinner.gif file remains.

    Added this to my functions;

    add_filter("gform_akismet_enabled", "__return_false");

    No conflict mode is 'on'
    Akismet Integration is set to 'no'

    Posted 8 years ago on Friday March 15, 2013 | Permalink
  9. David Peralty

    Most likely it is a theme or plugin conflict, can you try the following steps to isolate please?
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 8 years ago on Friday March 15, 2013 | Permalink