PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Not All Entries Coming Through

  1. I've got something weird going on with my contact form. It's at artofmanliness.com/contact.

    When people use the form, some messages will end up under entries. It works fine.

    But For a lot of people when they hit submiit, the contact page refreshes but they don't get the success message and I don't get the message in my entrie section. To the submitter it looks like it worked because the form clears, but I don't get the message. Basically it doesn't work.

    To check this, I Tweeted a bunch of my friends to send me something through the contact form and then tweet me again after they did it so I could see how many of the entries went through. Out of 5 only 1 got through.

    Why the hit and miss? Whenever I submit somethiing with the forms it works everytime, but for most people it's not working. It's frustrating becuase I probably missed out on a ton of potential opportunities without even knowing because I never got the message.

    Help!

    Thanks,

    Brett

    Posted 9 years ago on Thursday July 8, 2010 | Permalink
  2. Also, FYI i'm running supercache on my blog if that makes any difference.

    Posted 9 years ago on Thursday July 8, 2010 | Permalink
  3. Yes, that makes a difference. It could be something with your caching configuration causing the issue. For example older versions of W3 Total Cache caused problems when data caching was turned on because it was caching everything, including form submissions. They have supposedly changed this in the most recent version of W3 Total Cache but we still recommend not using data caching because of the issues it can pose.

    As for supercache, you may want to try deactivating it and then doing testing and review the settings for anything that looks like it could interfere with the data.

    Caching can play all sorts of tricks on pages and forms that need to work with live data and post live data.

    I wouldn't rule out another plugin conflict of some sort with another plugin you have running. Because we do have users that use supercache and this is the first time this has been reported.

    Posted 9 years ago on Thursday July 8, 2010 | Permalink
  4. I've been having this same problem this fall (wellmadedesign.com/contact). Both times it was a referral so the people found another way to get in touch. At the same time, I'm getting form submissions from other people. I want to say it is a user error of some sort but since it has now happened twice, that I know of, I thought I should reach out.

    I don't have W3 Total Cache installed.

    Thanks for any help!
    -EE

    Posted 7 years ago on Wednesday November 14, 2012 | Permalink
  5. David Peralty
    Administrator

    It is hard for us to troubleshoot these types of issues unless you are able to find someway to repeat the issue so we can find a source. We could do a thousand things, but how will you know it worked or didn't work?

    Posted 7 years ago on Thursday November 15, 2012 | Permalink
  6. SunPrinting
    Member

    Using form to upload customer file and info. Some files upload successfully while others load to 100% on the progress bar but when they say communicating with the site address and the process stops. There is no error reported nor text stating a success. Customers think they have finished the process but the file never reaches the upload folder or even Dropbox when we had that gravity form plug-in initiated. I know that the timeout for file upload is 300 seconds and the file upload takes less than that. Also the max file size upload is 64 mb and the files that have failed have all been below this file size. It does seem that files over 10 MB are more likely to fail based on testing results I have tried but this is not always the case. I have also tried a variety of file types based on the file requirements we have set(pdf, zip, doc, docx). I have also set up the form on this test site that has a default WP theme and no additional plug-ins so I have ruled out interactions with other programs. WP version 3.5 / php 5.3.8

    This is the URL for the dummy site that has a single gravity form including a file upload feature.
    http://temptestblog.angela.sunprintinghost.com/home-page/

    Posted 7 years ago on Friday December 14, 2012 | Permalink
  7. SunPrinting
    Member

    Don't know if these settings are inportant but this is what is in the main domain php.ini file
    ;;;;;;;;;;;;;;;;;;;
    ; Resource Limits ;
    ;;;;;;;;;;;;;;;;;;;

    ; Maximum execution time of each script, in seconds
    ; http://php.net/max-execution-time
    ; Note: This directive is hardcoded to 0 for the CLI SAPI
    max_execution_time = 30

    ; Maximum amount of time each script may spend parsing request data. It's a good
    ; idea to limit this time on productions servers in order to eliminate unexpectedly
    ; long running scripts.
    ; Note: This directive is hardcoded to -1 for the CLI SAPI
    ; Default Value: -1 (Unlimited)
    ; Development Value: 60 (60 seconds)
    ; Production Value: 60 (60 seconds)
    ; http://php.net/max-input-time
    max_input_time = 60

    ; Maximum input variable nesting level
    ; http://php.net/max-input-nesting-level
    ;max_input_nesting_level = 64

    ; Maximum amount of memory a script may consume (128MB)
    ; http://php.net/memory-limit
    memory_limit = 128M

    What I have set in the subdomain directory php.ini file is
    <?php
    upload_max_filesize = 64M
    post_max_size = 64M
    max_execution_time = 300
    ?>

    Posted 7 years ago on Friday December 14, 2012 | Permalink
  8. Can you put a php info file in the directory where you have your custom php.ini, and load it in a browser to see if the changes you are making in your custom php.ini are actually having an effect? Add this to a file and call that file up in a browser:

    <?php
    phpinfo();
    ?>

    Save that as info.php, maybe, and call it up here:
    http://temptestblog.angela.sunprintinghost.com/info.php

    Posted 7 years ago on Wednesday December 19, 2012 | Permalink
  9. Also, how do you know the uploads are failing? Do you have an error where the uploaded file should be, in an entry or email notification.

    Posted 7 years ago on Wednesday December 19, 2012 | Permalink
  10. SunPrinting
    Member

    Okay, I've added the phpinfo page and you can access it at
    http://temptestblog.angela.sunprintinghost.com/info.php

    There is no message when the upload fails. It just refreshes the page you were on without any changes. Customers contacted us that they sent files. We stepped through things with them. I was able to witness 4 failures out of twelve upload attempts. The bigger the file the more likely to fail but noticed I tried sending the same file twice and the second time it went through. I think it is a time issue where the upload is just stopping before it can complete. This site is a sub-site on a reseller account. I have added a php.ini file with the following code...
    <?php
    upload_max_filesize = 64M
    post_max_size = 64M
    max_execution_time = 300
    ?>

    But it seems to be reading the settings from the public.html php.ini file which is set at 30. Can I duplicate the public php.ini file from the main home folder and put it in the sub-site home, change the settings and save it there?

    Posted 7 years ago on Wednesday December 19, 2012 | Permalink
  11. SunPrinting
    Member

    I added the following to the php.ini file at the same level at the wp-config file for the subsite but I don't see a change in settings when I view the info.php page.

    upload_max_filesize = 64M
    post_max_size = 64M
    max_execution_time = 300
    max_input_time = 300

    Posted 7 years ago on Wednesday December 19, 2012 | Permalink
  12. SunPrinting
    Member

    I think the real hang up is the file size upload limit is set at 10M but no matter where I try and change the settings nothing changes. Everything that fails loads until it hits 100% and then nothing. No error message. Things below 10mb seem okay but I did have one instance when it gave me an error page that said the webpage was not longer available.

    Posted 7 years ago on Wednesday December 19, 2012 | Permalink
  13. David Peralty
    Administrator

    You might want to contact your host about that limitation as they might have the server set to stick to their settings as a security thing.

    Posted 7 years ago on Wednesday December 19, 2012 | Permalink
  14. SunPrinting
    Member

    I missed one of the settings that needed to be changed in the php.ini file. Once I changed both the fileuploadsize and the postsize everything fell into place. Thank you so much for you help on this matter.

    Posted 7 years ago on Thursday December 20, 2012 | Permalink
  15. David Peralty
    Administrator

    Glad you were able to figure it out. All my best!

    Posted 7 years ago on Thursday December 20, 2012 | Permalink

This topic has been resolved and has been closed to new replies.